Under my Windows 10 Pro Version 1607 Build 14393.321 i recently ran in into font-size issues inside of management studio (see screenshots below).

I am not certain if the cause of the "font-size issues" appeared

  • after i Installed redgate sql source control 5.3 on Microsoft SQL Server Management Studio 10.50.2500.0
  • or if an Win 10 update was responsible

Font size in Management Studio while still loading plugins

It seems that at first the font-issue are not present until redgate loads

Font size before redgate is loaded

Font-Size after plugin was loaded

But as you can see after the plugin was loaded the fonts are squished.

Font Size after plugin loads

Buggy option dialogues

What have i tried

My /settings/system/display/ for screen and text are set to 150% (for more info see how to change icon and system text size).

The answer to Windows 10 is squashing a few buttons, labels was to go to "Settings" > "System" > "Display" and make sure the slider is set to 100%.


But this is not an option for me because the fonts in every application are to small that way.

  • What can i do get my old settings inside management studio back?
  • What can i do to get rid of the tiny font-size and the huge icons in management studio?

By chance i have run into SSMS in High-DPI Displays: How to Stop the Madness:

The only complaint with it is windows and its (in)ability to scale applications when running at High DPI. I am running at maximum resolution (3200 x 1800) with 200% scale factor .... [some] applications scale horribly. For instance, SSMS (SQL Server Management Studio) 2014 is a complete disaster

Scott Hanselman posted Examples of Poor High-DPI behavior in early 2014.

Taken from comments from 2013 from the Connect item that describes this issue:

Walter A Jokiel, Program Manager, SQL Server: You can quickly implement that change yourself by following the "Disable display scaling on high DPI settings" instructions here rather than waiting for a SQL release vehicle to universally implement the change. Please let us know if this doesn't work for you.

Adam Robinson: Hi, thanks for responding. While I can understand this being a lower priority, could you at least modify the application manifest so that Windows runs SSMS in compatibility mode? This will render everything at the default DPI, so things might be blurry, but at least the text in dialogs would be readable.

With SSMS 2016 this may be fixed (not tested myself yet). Otherwise you can try to check the trello board for SSMS 2016


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.