1

New laptop, but same habits: I want the grub timer for boot to be at 1 second instead of the 30 when selecting between windows and linux. Therefore I did the usual:

  1. vim /etc/default/grub
  2. change to GRUB_TIMEOUT=1
  3. update grub

(all of the above from a root terminal, ofcourse)

However, the timer is still stuck at 30 seconds.

I've done this plenty times before, the only things that have changed are:

  • New laptop (Toshiba Portege, 13.3")
  • Newer version of linux mint (18 Sarah xfce)

Did I miss anything? Has there been a change between Mint 17 and 18?


My /etc/defaults/grub looks like this

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
#GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=1
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""
2

This issue turned out to be a classic case of PEBCAK. Somehow it never dawned on me that I needed to run update-grub2 as opposed to what I did: update-grub. Old habbits die hard.

| improve this answer | |
  • PS: /usr/sbin/update-grub2 is a symlink to /usr/sbin/update-grub on Ubuntu – Gaia May 24 '19 at 3:25
1

On my Linux Mint 18 installation I had the same issue. The following settings worked for me:

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=1.0
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
| improve this answer | |
0

If you like a timeout of X seconds try this:

GRUB_TIMEOUT=X
GRUB_RECORDFAIL_TIMEOUT=X

Work for me;)

| improve this answer | |
-1

Try "01" instead of "1".

Worked for me ;)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.