11

I've added a second monitor to my PC. And I've configured it to be in portrait mode and everything is fine when I'm in windows. But when I restart, the boot screen shows in the portrait monitor. I've searched all over the BIOS but found nothing. Switching the cables and ports also did nothing. So how can I fix this problem and set the landscape monitor as my primary display?

  • If you really did switch the ports around and checked your BIOS there isn't much you can do. Except maybe turn the portrait one into landscape and the landscape one into portrait. – Seth Nov 4 '16 at 12:32
  • 1
    What are the cable and connector types? What screen is connected to what display output? What is your graphics card setup? (One integrated and one dedicated graphics card? Dual display output? Two sepparate outputs on dedicated card? – Wouter Nov 4 '16 at 14:18
  • @harrymc I'm working with windows 10 professional. and about the second question. if the portrait one is turned off. it shows nothing on the landscape monitor – hmak.me Nov 5 '16 at 14:03
  • @Seth that's my last option. but are you sure there is no way to fix this? – hmak.me Nov 5 '16 at 14:03
  • @Wouter cables are DVI-D (Dual Link). My graphics card Is. Gigabyte GTX 760 Windforce and It hast two DVI outputs and I've plugged the monitors to the both of them. – hmak.me Nov 5 '16 at 14:07
1

(Windows 10, NVIDIA nvidia quadro p2000)

Had a similar problem with a triple monitor setup. The solution was to boot into the BIOS and switching plugs going into the graphics card (while still in BIOS) until the correct physical display showed up.

Windows seems to identify each display by some hardware ID because it still shows them in the same physical order, including primary screen that previously was set in settings, once back in Windows, the display numbering in Settings/Display changes though and apparently is related to the ports.

0

I'm gonna go ahead and post this debug plan as a separate answer, so we can discuss the details in the comments.

I want to figure out ...

  • if the problem is GPU DVI output specific. So, I want to make sure I understand correctly what you mean by "Switching the cables and ports also did nothing".
  • if the "portrait mode" is relevant in the issue. So you should try setting this to landscape, and try again with monitor 1 on output 1, and then monitor 1 on output 2.
    • If the portrait mode is relevant in the issue, you should upgrade your BIOS driver and GPU firmware (just to make sure you're at the latest version). Then test again. If the problem persists, you should open a support ticket with your GPU or Motherboard vendor (not sure which of the two would be most relevant), then it sounds like a firmware issue.
    • If the portrait mode is not relevant in the issue (would be weird). It must be screen specific. Yet, to be completely sure it's not the cables, try a full swap of both (so screen 1 - GPU 1 stays screen 1 GPU 1, just using the other cable).

For good measure, I'd like to get the details on the connectors and cables straight (for reference):

  • Your GPU has one DVI-D (dual link) and one DVI-I (dual link) connector, right?
  • Your cables are both DVI-D (dual link) cables, as you said?
  • What are the connector types on your monitors?
  • I've switched cables on same ports to be sure about cables. And I've also changed ports for each monitor. (port1 - monitor1, port2 - monitor2) and (port1 - monitor2, port2 - monitor1). And yes it has a DVI-D and a DVI-I. and my cables are both DVI-D. and my monitors have VGA and DVI-D connectors. my monitors are (Samsung S20C325B) – hmak.me Nov 7 '16 at 21:09
  • It might be that the EDID, or missing EDID (plug and Play data in the monitor), is causing the video card BIOS to detect the portrait display as the connected display. Could the landscape display have a bad cable connection or bad Plug and Play making the video card BIOS not detect it? Many of the cheap Chinese DVI to HDMI adapters don't populate Plug and Play data pins. Once the OS loads it is smarter and enables both displays. – Alex Cannon Feb 21 '19 at 19:56
-2

To Easily set Windows to start on a designated monitor every time you start windows/log in:

  • open Scheduled tasks: C:\Windows\System32\taskschd.msc
  • on left column, select Task Scheduler Library to be able to view tasks
  • on right column, select Create Basic Task
  • enter name for task (with no spaces, example: Monitor_Startup), click next
  • select When I log on for When do you want the task to start?, click next
  • select Start a program for What action do you want the task to perform?, click next
  • enter c:\windows\system32\displayswitch.exe for Program/script (when entering all data on my post, only enter the data between the ' 's, do NOT enter ' 'single quotes)
  • enter /external OR /internal for Add arguments (optional): (sometimes you have to guess which argument to use, because they are not necessarily named according to which monitor you think is internal/external)
  • click Finish
  • reboot and see if you have the right argument (/external or /internal),
  • if windows started on the correct monitor, you are finished, windows will always start on the same monitor.

If windows still starts on the wrong monitor, modify the task to switch the argument: - open Scheduled tasks: C:\Windows\System32\taskschd.msc - on left column, select Task Scheduler Library to be able to view tasks - in the middle column, locate the task you created (scroll if necessary), right click it, click properties - click the Actions Tab, click edit - switch the argument (/external from/to /internal)` , and click ok twice - reboot. Windows will always switch the monitor when you log on.

If you choose to stop this scheduled task, delete it: - open Scheduled tasks: C:\Windows\System32\taskschd.msc - on left column, select Task Scheduler Library to be able to view tasks - in the middle column, locate the task you created (scroll if necessary), right click it, click delete, click yes.

I hope this resolves your problem.

  • windows logon screen is showing up on the correct screen. the problem is on boot time. i wanna fix the monitor order in the boot screen – hmak.me Nov 5 '16 at 14:01
-2

other than setting the other monitor as a slave.

I would recommend switching accounts. Logging in as new user/guest.

Windows key + P

selecting the main display. Which should show as either 1 or 2.

then the option to make this my main display. Restart the computer. force log off the other user.

-4

If you are on windows 10 go to settings -> display -> click on your monitor you want as your primary monitor, then scroll down until you see "Use as your primary display" or something like that.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.