0

I'm trying to enable zswap on my digitalocean Ubuntu 16.04 droplet without any luck. I tried to apend zswap.enabled=1 to grub's GRUB_CMD_LINUX_DEFAULT and to GRUB_CMD_LINUX and after that run update-grub.

I also trie to enable it in runtime by executing echo 1 > /sys/module/zswap/parameters/enabled as suggested by ArchWiki but it tells me that /sys/module/zswap/parameters/enabled: No such file or directory, folder parameters contains only max_pool_percent.

As I've read zswap was merged into 3.11 kernel and I have 3.13.0-57.

Anyway dmesg | grep zswap shows nothing. Is there any way I can enable it in such configuration?

0

Well, after I upgrade my kernel to 4.4 problem gone. Zswap works now.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.