0

Windows 7 x64. ASUS P8H67-I. Intel video.

I've tried five different wireless mice, three from Microsoft (two USB dongle, the other Bluetooth) and two wireless from Logitech (both dongle). I've reinstalled all USB drivers and Bluetooth drivers and have installed the latest Intel 64-bit video drivers.

With a two monitor setup, there is truly horrible mouse-lag, the left monitor worse than the right. It is like trying to point at a single letter or number on a blackboard using a slender tree branch that is 15-foot long and very flexible. You just can't aim it accurately and it has "whip" which causes the tip to wander and overshoot the mark. It isn't just slowness.

A wired mouse does not have the problem.

Putting the mouse very close to the dongle has no beneficial effect. It's not a distance issue. Fresh batteries.

Putting the dongle in a different USB port has no beneficial effect.

Sometimes turning off the mouse for a few seconds and turning it back on will give me a few minutes of acceptable use. But it quickly deteriorates.

  • I'm using both MS (sculpt comfort) and logitech mice with two monitor setup without any issue. Does it appear only if there are two monitors? Do you have any other performance issue with the pc? Are there anything might disturb your signals? – Máté Juhász Nov 2 '16 at 11:47
  • Single monitor setup works fine. No other performance issues. I can't think of anything that would be disrupting the signal. I should add that I have identical M/B at home and at the office, and both PCs have two monitors, and the problem appears on both PCs. – TRomano Nov 2 '16 at 11:49
  • 1
    Possibly related: communities.intel.com/thread/33324 – TRomano Nov 2 '16 at 11:51
0

I found what's causing it in my case - apparently it was CPU throttling - that's when your CPU gets too hot and puts on breaks, this apparently has negative effect on some devices like Bluetooth. My solution was to use laptop cooling pad, you could try just lowering maximum performance in advances power settings if you have no other options. No other solution worked for me and it is definitely not WiFi interference or any setting in my case.

  • I would note that probably second monitors in your case increases CPU load - so there is no direct connection, just indirect. I know this is pretty old question but problem is common, maybe will help someone else. – Valters Jun 26 '17 at 23:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.