28

When I search in the Windows Start Menu, I am not seeing the expected results returned for programs I want to run. Below are some screenshots, the first of me browsing for SharePoint (to illustrate it's on the system) and the second showing me searching for SharePoint and not having it show in the results.

enter image description here

enter image description here

I have gone into Control Panel, Indexing Options, Advanced, and forced a rebuild of the index and it had no impact.

There are other examples of it not working, and examples of it working (if I search for Chrome, it comes up with Chrome). I don't understand the difference.

9

The issue is discussed on this Microsoft support page. Basically you just need to enable the Windows Search service:

  1. Press the Windows key‌ + R to open the Run box.
  2. Type services.msc, and then press Enter.
  3. Right-click Windows Search, and then click Properties.
  4. Change the Startup type to Automatic (Delayed Start).
  5. Click Apply, and then click Start.
  6. Click OK, and then close the Services console.

It may take a while for it to index everything and make it available to be found by the search.

  • 1 week after having carried this out mine still produces the same "No results found" :( – Jimbo Jan 12 '18 at 13:19
  • 1
    I've found that this solution at least partially works @Jimbo. Some things like the System Information app and System settings page now come up in the search, but other things like the Internet Information Services (IIS) Manager still don't populate in the search for some reason. It's definitely better than it was before though (which was always no results for any search), at least for me. – deadlydog Jan 12 '18 at 15:32
  • 2
    This was already enabled on my VM, but I still experience this problem, so this answer does not work for me. – Anssssss Mar 6 '18 at 16:58
  • Complete solution for me: this one and that bellow other, about Built-in Administrator account policy. Anyway, that started completelly wrong: I (we!) should never used the built-in admin account for a starter :-) – Marcus Vinicius Pompeu Jul 18 '18 at 14:23
6

We had the same problem with our Windows Server 2016 Standard installation. We could fix it by following this guide. Don't be confused that it addresses another problem. You can test if this will work for you, if you open the startmenu and run "Cortana & Search Settings" (just type "search", it will be found, even with the broken startmenu). If it shows

Search can't be opened using the Built-In Administrator account. Sign in with a different account and try again.

then the solution in the guide will work.

For future references if the guide gets unavailable:

  1. Run gpedit.msc
  2. Go to Computer Configuration > Windows Settings > Security Settings > Local Policies > Security Options
  3. Enable the policy User Account Control: Admin Approval Mode for the Built-in Administrator Account
  4. Restart the server. Signing out and logging in again doesn't suffice.

Be aware, that this solution has the downside of half-enabling UAC again for the built-in administrator. As long as EnableLUA is deactivated, it should not annoy you, but I am not experienced enough to tell if it has any other major side effects.

  • 4
    This did not work for me. Perhaps it works for the bulilt-in administrator but it did not seem to have any effect whatsoever on a domain-based administrator account. – briantist Feb 21 '17 at 19:23
  • Thanx! Although I also had (already had done) to start the Search service as stated in the previous answer. Anyway, I should never be using the Admin account for a starter (remark: it's a dev vm server, not a live production one :-) ) – Marcus Vinicius Pompeu Jul 18 '18 at 14:25
  • @briantist Few Positions Lower in the Security Options there is Admin Approval Mode for All Administrator - This did work for me – efkah Jan 17 at 16:17

protected by Community Jul 31 '17 at 12:05

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.