0

I have a Dell laptop with two docking stations, one at home and one at work. Often when I go from home to work, I just close my laptop (which puts it to sleep) and when I plug it into my work docking station, only the laptop screen comes on and the devices plugged into the docking station don't work. The only way to fix it is to do a complete shut down and reboot. It's like the computer wakes up and doesn't recognize the docking station it's on. I'm pretty sure they're the exact same docking station both at home and work. Any ideas on how to fix this?

  • OS: Windows 10 (All latest updates)
  • Laptop: Latitude E5470
  • Docking Station: Dell E-Port Plus
  • Have you tried updating your drivers since the anniversary update? I have seen similar issues with dell products. We had a dvd drive that would only recognize disk that were in the drive during boot up. – Cody Pace Nov 2 '16 at 17:00
0

Since the laptop seems to failing on two different docking stations, check the connector on the bottom of the laptop. Make sure no debris is in covering the pins that connect to the dock. Also, make sure no pins are broken or bent.

Also, here are a couple of things to try if the above doesnt apply:

  • Make sure your BIOS for your laptop is up to date.
  • Boot with Legacy ROM disabled
  • Enable Legacy ROM and disable Secure Boot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.