My applications folder won't allow Quicken to update so I tried to add my user name to the applications folder and give it read/write. I don't see staff permissions either and a "fetching" that never shows anything. But is says I don't have sufficient permissions to make the changes. Terminal whoami says I am root.

Trying to use this solution : Cant change permissions

I tried sudo bash and chmod, but

Go this error: chmod -R g+w /System chmod: Unable to change file mode on /System: Operation not permitted chmod: Unable to change file mode on /System/.localized: Operation not permitted

I have this issue on an applications folder which Quicken is trying to update but fails on installation. Nothing asks for my permission. I'm an admin but can't change permissions with Get Info on the Folder, saying I don't have permission...

Anyone have any ideas? DiskUtil no longer has a separate function for permissions repair...

  • 2
    This is a very confused question... why are you logged in as root?? It's not even enabled on Mac by default. It's not needed for anything on Mac. Admin & sudo are sufficient, unless you're fighting SIP, which even root cannot bypass on a running OS, & which you switch off from Recovery using csrutil disable, then back on once finished. Apart from that, the worst thing to do is try chmod system folders, it can only end in tears. – Tetsujin Nov 2 '16 at 19:24

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.