I have an airport extreme with a drive connected, and use it for backing up snow leopard macs. I have an occasional problem with one of them that says "the backup disk image ... is already in use" and it fails to backup.

Any ideas?


What worked for me in the end was to "disconnect all users" from the Airport Utility - and then unplug/plugin the drive again (remount it) - it was then able to backup successfully.


There isn't an .InProgress file still on the drive is there? That can cause problems. Just delete it to get the backup working again.

  • This is a pretty good suggestion; upvoted.
    – Alex
    Mar 17 '10 at 14:38

The disconnect, power off/on works, but only temporarily. I think for me it hoses up if I close my macbook pro lid while its trying to backup.

  • FWIW - this seems to be solved now, post a few updates to OS-X Nov 17 '10 at 22:29
  • does not seem to be fixed in 10.7.1 Sep 5 '11 at 23:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.