7

So the other day, there is a post about this here but there have been some developments, I installed Linux Kali to dual boot and messed up the booting of my PC.

After messing around with the boot files I finally got it to boot the Windows 10 partition using this code

menuentry 'Windows 10' {
  set root='(hd0,msdos1)'
  chainloader +1
}

But it failed and I got a message similar to this.

File: \Boot\BCD

Status: 0xc0000034

Info: The Windows Boot Configuration Data file is missing required information

Yes that is the one for Windows 7, I couldn't find the Windows 10 version. I believe the error code and extra information was different.

To fix the problem I followed these steps found here and here (the BurrWalnut answer)

  1. Put the Windows installation disc in the disc drive, and then start the computer.
  2. Press a key when the message indicating "Press any key to boot from CD or DVD …". appears.
  3. Select a language, a time, a currency, and a keyboard or another input method, and then click Next.
  4. Click Repair your computer.
  5. Click the operating system that you want to repair, and then click Next.
  6. In the System Recovery Options dialog box, click Command Prompt.
  7. Type BOOTREC /FIXMBR, and then press ENTER.
  8. Type BOOTREC /FIXBOOT, and then press ENTER.
  9. Type BOOTREC /REBUILDBCD, and then press ENTER.

The problem is when I enter the command BOOTREC /FIXBOOT the output is Element not found and when I enter the command BOOTREC /REBUILDBCD it scans for operating systems, finds windows, asks if I want to add a boot for it, I enter Y and then it gives the output Element not found.

I would really appreciate any help in fixing the problem

  • 1
    Is this an MBR or GPT drive, and is this a BIOS or UEFI motherboard? – oldmud0 Dec 30 '16 at 23:31
  • @oldmud0 It was a GPT drive and I'm not sure what you mean by the second question. However, the problem has now been resolved. Thank you for the comment – Dan Dec 30 '16 at 23:35
  • 1
    Please answer how you resolved the problem. That's your way of giving back to the community, otherwise we'll keep scratching our heads here. – oldmud0 Dec 30 '16 at 23:36
  • @oldmud0 I reformatted the hard drives. Unfortunately I was not able to fix the specific problem so I started again – Dan Dec 30 '16 at 23:41
9

For anybody else that experiences the same problem (completely shot my windows boot partition while installing Linux) and stumbles across this question, I suggest giving the troubleshooting steps from Dell a try. Instructions are for UEFI and GPT only I think.

The command that finally fixed my problem was:

bcdboot c:\Windows /s <boot letter>: /f ALL

For different systems, different variations of the command parameters might be appropriate.

| improve this answer | |
  • Thank you for the answer. Unfortunately as the problem occurred so long ago I have no way to test the solution you gave. I'm glad it worked for you though – Dan Jun 14 '17 at 23:01
  • 2
    Yeah, I figured as much, but I came across this question earlier and wanted to provide some help for people who'll have the same issue in the future.. (or maybe it will happen to one of us again ;) ) – Luis Dunkum Jun 14 '17 at 23:03
  • Finally! Thank you very much for your time finding this out! – toesslab Jan 4 '19 at 15:25
4

I found a quite extensive article about recovering from boot problems for almost all Windows versions: https://neosmart.net/wiki/bootrec/

BTW, it also states about the above mentioned bcdboot command, but with the correct parameters (the line mentioned in an answer above is lacking f.ex. the /f before the ALL, so the complete command would be: bcdboot C:\Windows /s x: /f ALL

In my case, the Windows system was already detected on C: so instead of x: I just used c: and it worked and recovered.

| improve this answer | |
  • 1
    Hello, welcome to SuperUser! You may want to add more details to your answer. While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. – Nathan.Eilisha Shiraini Jun 30 '17 at 7:06
  • Thanks for the answer but the problem has been resolved so there is no way to test this for me. I'll keep it in mind if I ever have the same problem though. Thanks for the answer – Dan Jun 30 '17 at 7:23
  • This worked for me. For some reason my c:\boot had disappeared and the bcdboot command fixed it. – JumpingJezza Apr 3 '19 at 0:07
2

I've been battling with this problem for a couple of days after the Windows update - was beginning to thing that I's have to do a clean install of years of applications.

Came across this forum by accident and have to thank Sven Rieke for his solution and comments - brought my system back to the point of the update where it had failed to boot and am now back working again. Can't thank you all enough.

The solution - as described was

Boot Win10 installation - troubleshoot - command prompt logged into drive c: bcdboot c:\windows /v /s c: /f ALL

Using /v gives a good idea of the problems that are on the system - and for me they were legion. I've no lost 2 installations of Linux / Ubuntu from my disk but now have a clean windows - and that is what I was looking for.

Now all I have to do is bring up some YouTube videos on plastering to repair the wall that I've been banging my head against for the last couple of weeks

Cheers

| improve this answer | |
0

Check if the partition that you want to boot from is set to active

You can make use of diskpart in the command prompt to check the partition of the disk

| improve this answer | |
  • Thanks for the answer but I have already tried that and the problem has been resolved. Thanks for the answer – Dan Dec 30 '16 at 23:39
  • Active partitions are a thing of the past from the BIOS/MBR era. Drives should all be GPT now and boot should be UEFI – Magix Sep 8 '19 at 19:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.