0

I have a table in Word 2013 which spans a page and a half and covers pretty much the full width. I would like a caption above the table which will remain attached (visibly) to it. By that, I mean, no page gaps between the caption and table.

My "caption" is just a line of text that I've formatted (I tried using a proper table caption, but a) it didn't change the behaviour I will describe below and b) it always has a number attached, that I cannot seem to get rid of).

So, the problem. In Table Properties, with Text wrapping set to 'None', I get the header row repeated on the subsequent page - yay! But, the table then decides to not start at the position I originally had it at, but rather, starts itself on a new page, fills that page, then moves on to the next page.

If I change Text wrapping to 'Around', then the table starts where I want it to, but, I have no repeating table headers.

Finally, if I tried to use that + arrow grabby thing at the top left of the table, to move the table around, the table doesn't move, but rather, snaps itself to very top edge of the page (even over the page header)!

Other tables in the doc behave properly. I don't know if this behaviour is due to the size of the table or something else, but I cannot figure out what is causing it to act this way.

Sample Doc

Vid Showing Strange Behaviour

0

I believe this is a behaviour that Word does with multi-page tables

fixed

  1. In Table Properties, set the table's Text wrapping to None.
  2. From the Ribbon\Table Tools\Layout, grouped above Data, release the button Repeat Header Rows (look at the top-right button in the attached image)
  3. If you indeed want to repeat the header, click again the button Repeat Header Rows.
  4. Remove extra line spaces.

If you like to use the automated numbering caption, make sure when you insert it

  1. From the Insert Citation dialogue box, click button Numbering...
  2. Un-tick Include chapter number. then confirm.

This should use 1 number for your caption. And don't forget to choose your preferred label, e.g. Table, Figure for your table.

  • I went through the steps as you described and I got it to behave nicely, but, I still cannot move it around using the little + grabby thing. Have a look at the vid I captured (added to OP). – Jon Nov 9 '16 at 17:14
  • @Jon Note that as soon as you grab the table with the + handler, you'll change its Text wrapping from None to Around. And since the table spans another page, it becomes difficult for you to move the table freely, even if you try to use the Positioning button inside Table Properties. How do you want the table to look like? – Sanny Nov 9 '16 at 17:48
  • Well, I thought that by grabbing that handler, I could move the table around like any other table (which fits within a single page boundary). I guess my expectations simply don't jive with reality. – Jon Nov 9 '16 at 19:00
  • 1
    @Jon I noticed in your sample file that you use fixed row height. You can have a compact table in one page if you don't specify the row height or decrease it. :) – Sanny Nov 9 '16 at 19:09
1

As to the caption: If you don't want it numbered, just type the caption text in a paragraph, and turn on the paragraph's Keep with next setting. (You should also turn on that setting for the paragraphs in the header row, so that you don't end up with just the header row at the bottom of a page.)

As to the page break when you set Text wrapping to None: It sounds as though you have the Allow row to break across pages setting turned off, and/or some of the paragraphs have the Keep with next setting turned on.

  • The 'keep with next' is a good suggestion! – Jon Nov 9 '16 at 17:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.