13

I was working on a project, and my display driver crashed (the black screen, then redraw). When it came back, my screen was no longer extended, but mirrored. I went to the display settings, and I now see a display as “1|6” and another as “5”. I have no idea what that means.

display settings with “1|6” and “5”

In addition, when I try and extend the display, I get crazy things like this:

display settings with “2|3”, “1”, “5” and “6”

I have a Dell laptop with an Intel HD Graphics 4600 and also an Nvidia K4100M.  My Dell U3011 external monitor is connected via DisplayPort.

The device manager now shows the above plus five “Generic” monitors:

Device Manager: Intel and NVIDIA display adapters, Dell monitor, and more

Has anyone ever seen this before? Any solution to get back to the basic 1, 2 monitor configuration?

  • Windows 10 x64, fully updated
  • Nvidia and Intel drivers I also fully updated still without any change.
  • I have rebooted several times.
  • When I remove the extra “Generic” monitors from the Device Manager, they come right back.

Going to do a safe mode, and delete all the Generic displays, although I have no idea how they even got there. Any help is greatly appreciated.

4
  • Have you rebooted? When a driver crashes it is reinitalised and that may give weird results. A reboot usually fixes it.
    – LPChip
    Commented Nov 3, 2016 at 17:47
  • yep, several times. Also when I remove the extra monitors from the device manager, they come right back. I have an identical setup next to me, same Dell laptop, OS, configuration, those monitors do not exists. I feel like its somehow related to those extra monitors. Commented Nov 3, 2016 at 17:51
  • I have a similar problem with a MacBook, also running Intel graphics.
    – tyteen4a03
    Commented Feb 28, 2017 at 13:00
  • 1
    This looks like a known problem with the Intel graphics drivers and Hyper-V. communities.intel.com/thread/110642 Doesn't look like there is a fix yet. Reverting to older drivers seems to work. Uninstalling/disabling Hyper-V worked for me.
    – Simurr
    Commented May 24, 2017 at 14:49

9 Answers 9

9

I also had this exact problem. It is for sure related to the Intel drivers. I have a Dell M3800 and went and downloaded the drivers from Dell (they are much older) but it worked. I made sure to rollback, select specific drivers and installed by pointing to the extracted files.

More detailed steps (my problem came back after an update so I wanted to write more about it):

  1. Download https://downloads.dell.com/FOLDER03173279M/1/M3800_Video_Driver_7C6X2_WN32_10.18.15.4248_A00.EXE
    Warning: it is almost 200 GB; it will take a while.
  2. Run it and extract it to C:\dell; you may need to install it too
  3. Open “Device Manager”
  4. Update driver
  5. Open Properties of the Intel 4600
  6. Click “Update Driver”
  7. Select “Browse my computer”
  8. Select “Let me pick from a list of device drivers”
  9. Select the older version, 4248

Others have noted that Windows Update may push updates for the problematic Intel driver(s).

6
  • 2
    Going to give this the answer. I uninstalled the driver supplied by Intel, extracted the one from Dell (dated only one month before) and it appears to be working now. Hope it stays good, but solid recommendation. Not sure why the Intel one from Intel's site or windows update doesn't work right. Commented Nov 7, 2016 at 20:54
  • 1
    I had a very similar issue and for me it was just going to the Device manager and Rolling back the Intel Driver version. Commented Jan 19, 2017 at 17:18
  • 2
    Windows Update pushed an update for the Intel Driver today. It wreck havoc in my Windows Display causing this issue. Reverting to the previous Intel Display Driver fix the issue, reinstalling the latest version bring back the issue. So I guess there's something wrong in the version pushed from Windows Update. Commented Jan 26, 2017 at 2:11
  • I had this problem with a Dell M3800 laptop. I upgraded the BIOS & reinstalled Windows & it worked great after doing so. The Intel driver was the same, but the NVIDIA driver was slightly older. Intel HD Graphics 4600 driver remained version 20.19.15.4531. NVIDIA Quadro K1100M is now working with 10.18.13.5362, but not when it was 10.18.13.5390. The BIOS was upgraded from A9 to A10. If reinstalling Windows is an option, give it a shot. Commented Feb 3, 2017 at 22:09
  • With the reinstall of Windows 10, Windows installed all of the current drivers and I didn't have to manually download or adjust anything. I wiped my drive with gparted before reinstalling. Commented Feb 3, 2017 at 22:11
13

I think I have solved it by removing Hyper-V (came default with Win10 Pro).

I'm running windows 10 on a Lenovo T540p laptop and had as many as 7 displays showing up at one time. I ended up removing Hyper-V due to something else (Xamarin development), and noticed my screen blinking once. And this fixed it :)

After this I could both open Intel HD Graphics Control Panel, and install updated drivers. Didn't even need a reboot.

4
  • Prob the same issue I had -- also running Xamarin, Hyper-V under 10 Pro. That's a bit of a disappointment if that is the issue -- ill have to test it soon. Commented Jan 14, 2017 at 2:27
  • communities.intel.com/thread/110642 Seems to be a known problem. Don't see a fix for it and I'm not sure if/when Dell would update their driver even if there was a fix. Uninstalling Hyper-V fixed the problem for me.
    – Simurr
    Commented May 24, 2017 at 14:46
  • Yeah I just disabled it (Hyper-V) and went with Virtualbox for VM's Commented May 30, 2017 at 11:53
  • This solution worked for me as well, on an MSI laptop with an Intel 4600 and Nvidia 860M. My guess is that it's an issue with Hyper-V and not the video drivers. One thing to note, to disable Hyper-V locate 'Turn Windows features on and off' in the Windows control panel, and uncheck 'Hyper-V'.
    – Ben
    Commented Jul 1, 2017 at 21:08
3

I had a very similar issue, where I had my laptop connected to just one external monitor, making it 2 monitors in total. At a certain time, the external display was mirrored instead of extended, like it always was and in the display settings there were in total 6 displays showing. After checking, I realised that there was a Intel Display driver update on the windows update history, around the same time.

So I:

  • Went to the device manager;
  • Searched and selected the Intel graphics card, under 'Display Adapters';
  • Clicked on 'Properties' on the context menu and selected the 'Driver' tab on the pop-up window;
  • Selected the option for 'Roll back Driver...', clicked yes when prompted;
  • And after a mandatory reboot, issue got solved.
3
  • I am running windows on bootcamp and just installed docker and eventually got in to the same issue, I have no clue why the new graphic driver has being installed but the Rolling back... did the trick. Commented Sep 19, 2017 at 12:05
  • And now I am having that issue github.com/docker/for-win/issues/151 with a docker. Commented Oct 11, 2017 at 10:02
  • @Kuncevic I'm not sure but there seems to be certain triggers for display drivers to update. I've had this issues a few more times, with regular updates to windows and another case with Nvidia update. With docker is a first tough. Commented Apr 24, 2018 at 12:53
0

This may be of zero assistance as you've stated that your Nvidia is fully updated; however, it may help to first disable the extra monitors, then uninstall and reinstall your Nvidia Driver. Also, you may be able to see something in the event tabs w/in each monitor's properties that may guide you to some explanation as to what happened/how/why they were installed.

Please Note: I am not uber proficient by any means so do take my suggestion with a grain of salt! I am hoping for assistance on my own first question/post here and thought to read through other questions to see if I can help answer any thing/be of some value in return.

2
  • 1
    I found its actually related to the Intel driver. When I uninstall that driver, all the extra spare monitors go away. I think a windows update must have triggered this problem. Ill have to see about installing an older version. Commented Nov 4, 2016 at 4:27
  • Ah okie. Sorry I was not of more assistance to you. Commented Nov 4, 2016 at 15:38
0

What I did on this one was... 1)Right click on desktop and select display settings 2)Scroll down to multiple displays and select show only on 1,2,3 and so on. After this your screens should show how they're supposed.

0

BEFORE YOU MESS WITH YOUR DRIVERS: If you have two monitors and it's showing 1|2 instead of extending displays: Win 10: Go to Start/Windows System/Control Panel Verify both monitors show. Right click on one of them and go to Display settings Scroll down to Multiple Displays section and drop down the box. If it says Duplicate these displays, change it to Extend these displays. An update pushed to my Win 10 pc and reverted this setting. This fixed it for me.

0

I had the exact same problem on Windows 10 Pro and solved it by installing the Intel® Driver & Support Assistant tool.

This tool verified my computer drivers and guided me to download the right one.

After installation, I've rebooted my PC and the display issue has been fixed.

0

This also happens when you activate Kernel Isolation in Windows Defender (which uses virtualization) without Hyper-V per se being activated, where multiple non-pnp monitors show in Device Manager (4, to be exact, in my case; one per each, now isolated, cpu kernel?).

This with Intel HD Graphics drivers 20.19.15.4703, at least, and without any update happening in the mean time.

Disabling Kernel Isolation solves the issue.

-2

This is bug in the drivers from intel, they have a long discussion about this at https://communities.intel.com/thread/110642?start=60&tstart=0

1
  • 2
    Welcome to Super User. On this Q&A site we value answers that stand on their own. Hyperlinks alone point toward an answer without actually being one. Please edit your answer so that it includes the essential elements from your linked source. Commented Aug 7, 2017 at 21:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .