1

When I open vim (or gvim), it loads a list of buffers of files I have been working on. I want it to have an empty buffer list on startup. How can I accomplish this?

  • check your 'viminfo' setting – Christian Brabandt Nov 4 '16 at 6:42
  • Thanks for asking this question. Too many open buffers slows down Vim terribly. – user3751385 Aug 17 '17 at 1:04
3

You seem to have the % value in your 'viminfo' option; it enables restoring of the buffer list. As this is off by default, you (or your Vim distribution) must have turned that on.

:help viminfo-%:

% When included, save and restore the buffer list. If Vim is started with a file name argument, the buffer list is not restored. If Vim is started without a file name argument, the buffer list is restored from the viminfo file.

  • Thanks, I searched through my .vimrc and found that enabled. – Fela Maslen Nov 4 '16 at 17:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.