Google Chrome's New Tab Page is not populating the most frequented visted sites grid with anything:

alt text

It's been sitting like that1 for months. My work machine populates them fine.

Edit: Google Chrome Version

Edit 2: (Possibly related) Chrome is not storing any history

1 I even tried clicking Restore all removed thumbnails
2 Updated to just now. Previous build was 78.

  • What version are you using?
    – Kez
    Feb 27, 2010 at 13:39
  • @Kez:
    – Ian Boyd
    Feb 27, 2010 at 18:39
  • Any new answers to this? My Frequent Sites disappeared when updating to version 64 and the previous answers don't help.
    – baochan
    Feb 20, 2018 at 21:28

4 Answers 4


Chrome not storing history is the problem, the most visited websites are based on how often they come up in your history. If you are intentionally blocking chrome from storing your history then try turning your history on and visiting the sites you want on the new tab page then turning it off again(I do not know how to turn it on or off on command). If its unintentional then it seems like that would be your main problem.

  • Then we just have to figure out how to get Chrome to store history.
    – Ian Boyd
    Mar 2, 2010 at 1:41
  • 1
    i cleared my browsing history, and reset Chrome options to defaults, and now it's storing history - and tabs. You win.
    – Ian Boyd
    Mar 2, 2010 at 1:45
  • Glad I could be of help. The "You win" is a nice touch too :)
    – MESLewis
    Mar 2, 2010 at 14:52
  • Go to Settings, in Google Chrome.
  • Then, click on Show advanced settings.
  • At the very end, you will see Reset browsing settings.

Click on that: it will change to the default settings, but hey, it will also clear your browsing history and disable extensions. For extensions, you can enable it again if you have installed them like ad block plus or any other.

Hope that answers your question.


I encountered a similar issue. I turned off the"show trending searches" and my Frequently Visited sites returned. Right under the Google Search Box is where the Trending Searches was appearing and to the right of that was the "dots bar" giving the option to turn off Trending Searches.


just uninstall and reinstall Chrome 100% fixed tried and tested


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .