3

Recently, I have messed around trying to dual-boot Windows 10 and Ubuntu. It was a great failure with various problems. Long story short, I wiped my drive and installed Windows 10 fresh. The first thing I wanted to do was to boot into UEFI firmware settings (using Windows Advanced Restart) and disable secure boot and fast boot. However, the UEFI firmware settings boot option does not exist! As far as I can tell, it is impossible for me to boot to UEFI/BIOS (spamming F12, F2, del, etc. does not work either). So how can I boot to firmware settings, or restore them if they are broken? Surely they cannot be non-existent. Image of System Information:

System Information

  • 1
    Possible duplicate of Enter BIOS from Windows 10 (UEFI mode) – Ƭᴇcʜιᴇ007 Nov 4 '16 at 15:17
  • I don't think this is a duplicate; given user3608260's comment on Ƭᴇcʜιᴇ007's answer, it sounds like something's very wrong with the Windows installation or firmware. user3608260: What computer or motherboard are you using? (Make and model?) – Rod Smith Nov 4 '16 at 17:57
1

If you have Windows 10 running, you should be able to hold Shift while clicking "Restart" and you should get the troubleshooting menu.

On that menu, under Troubleshoot -> Advanced Options, should have an entry to reboot into your UEFI Firmware Settings.

enter image description here

Image source/more info

  • 3
    Yeah man, that's Advanced Startup. the UEFI Firmware Settings button simply does not exist, whereas every other option shown in that screenshot is shown for me. My System Information also confirms that BIOS mode is UEFI. – user3608260 Nov 4 '16 at 15:16
  • Then you are most likely in BIOS mode and not UEFI. Luckily I found an existing question that covers that.. check the question's comments for the "Possible duplicate" I flagged. – Ƭᴇcʜιᴇ007 Nov 4 '16 at 15:16
  • No keystrokes during startup will take me to UEFI firmware settings. Booting to Windows always overrides anything. I haven't tried rEFInd though, so I'll have a look at that. – user3608260 Nov 4 '16 at 15:22
  • The screen shot in the question clearly indicates an EFI-mode boot, so I suspect something is fundamentally wrong with the installation or firmware. – Rod Smith Nov 4 '16 at 17:55
0

As I've said in my comments, I think something's wrong with your Windows installation and/or the firmware on your motherboard. You may be able to force the system to boot into its setup utility by unplugging all the disk devices -- hard disks, USB flash drives, optical drives (or at least the discs), etc. When a computer can find no other boot devices, it will normally boot into the firmware setup utility.

If this works, I recommend you try one or both of:

  • Reset to defaults -- Sometimes a firmware's settings get damaged in a way that can cause weird behavior. Resetting all the settings to their defaults can usually fix such a problem. There's usually an option to do this somewhere in the setup menus, usually on a screen with options for saving settings and resetting the computer.
  • Enable boot-time options -- Various boot options can sometimes disable the sorts of keystrokes you've tried to use. You mentioned one of these ("fast boot"), but there are others, and names can vary. (Sometimes these options describe levels of USB initialization, and setting minimal USB initialization can cause the keyboard to become unresponsive.) If you have another computer (even a smart phone), try Googling option names as you peruse the menus to figure out what they do.

I'm not 100% sure of this, but I suspect that some very early EFI-based x86-64 motherboards might lack the features that Windows uses to produce the "UEFI Firmware Settings" option described by Ƭᴇcʜιᴇ007. If yours is more recent, though (anything made since 2012 or 2013, at a guess), it should have that option when you boot in EFI mode. If it doesn't, that could indicate a bug in Windows or some quirk to the way it was installed. Re-installing might fix the problem, but unless you can track down the cause that may just be pointlessly optimistic.

  • I tried booting with no disks installed, and it just gets stuck. If I press any key, "press F12 for boot options" comes up, but pressing F12 does nothing. Considering I wiped the drive and put a clean install of Windows 10 on, I'm not sure if reinstalling will fix the problem. By the way, my laptop is a Dell Inspiron 17R SE 7720, it's about 3 years old. – user3608260 Nov 6 '16 at 5:16
  • In that case, I suspect that something's badly corrupted in your firmware's NVRAM. It may be necessary to return the computer to the manufacturer for repair or replacement if you must get this working. At the very least, I'm out of ideas. – Rod Smith Nov 6 '16 at 17:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.