0

My brand new M.2 NVMe SSD SM961 arrived today, and I decided to check if it improved the performance on my XPS 13. I know it'll probably be bottlenecked by the x2 PCI-E interface, but anyway. If I don't see any improvement, it'll go in my desktop.

The installation of the drive went smoothly, the Windows 10 installation recognized the drive and everything was installed correctly (from USB) at the first attempt without touching anything, but after the installation it was impossible to boot from the drive: no bootable devices detected.

I tried:

  1. Install without UEFI (legacy): The Windows 10 installation can't create partitions / format the hard drive.
  2. Install with UEFI: Windows 10 install works, doesn't find a boot device after.
  3. Install with UEFI, then go legacy in BIOS: Recovery screen: winload.exe Error code 0xc00000e.

I don't quite understand why the Windows 10 installation is capable of detecting the drive & installing everything correctly, and then the computer is not able to boot after that.

I have the latest BIOS (A09).

I've also tried to manually create the hard drive in the UEFI Boot Sequence like this page explains, but then I got another Recovery screen when trying to boot Windows. I'm only able to do this when the USB media is connected (edit: yeah, you guessed, no SSD, only seeing the USB there). If I do it when it's disconnected, I get a"File System not found" prompt.

One strange thing I've noticed is that my BIOS doesn't seem to recognize the SSD, and the Dell onboard diagnostics either.

2 Answers 2

1

I finally ended up changing the motherboard for a 9350 one. It improves the 9343 in significant ways:

  • NVMe drives work.
  • It provides a USB-C Thunderbolt port.
  • Slightly new processor.
  • I upgraded from 8Gb to 16Gb in the process.

The 9350 motherboard has basically the same layout as the 9343, so switching motherboards is not very difficult if you follow the iFixit guide and some Youtube videos.

Overall, pretty happy with the upgrade.

1
  • 1
    Glad to hear you found a solution. Don’t forget to accept your answer! You may have to wait some time until you can do so.
    – Daniel B
    Commented Jul 31, 2017 at 10:22
0

If the BIOS recognises the drive, and you were able to install Windows 10 on it, then obviously it's not a hardware/compatibility problem. It's likely not even a driver problem, unless the drivers somehow were removed after installation or were specific to the Windows installation image but aren't included in the OS - which seems unlikely.

Have you checked the BIOS for "legacy boot", "compatibility" or "secure boot" settings? On Asus motherboards these need to be either disabled or set to allow UEFI boot devices in order for M2 drives to be bootable.

1
  • It's a Dell bios thing. Specifically with the xps 9343 series. I've personally tried three separate nvme drives in one that was brought to me for repair. None of them were recognized. Commented Aug 8, 2019 at 18:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .