24

Hi I installed Docker for Windows which enabled Hyper-V on my windows 10 machine. Unfortunately this caused Virtual Box to not work anymore, therefore I removed Docker again, but Hyper-V is still activated.

If I try to disable Hyper-V with any of those ways: http://www.poweronplatforms.com/enable-disable-hyper-v-windows-10-8/ on the reboot it will first try to apply the changes and than say that the changes couldn't be applied and reverts, so Hyper-V is activated again.

Has anybody an idea what could be the issue here?

  • No error with any of the methods? Did you check your Eventlog for hints what the error could be? What error(s) did you get from Virtual Box? – Seth Nov 5 '16 at 14:02
  • Virtual Box gives me a bluescreen whenever I try to boot a vm. Will try to find some error logs – Jakob Abfalter Nov 5 '16 at 15:39
  • copy the folder C:\windows\logs\cbs to the desktop, zip the folder and share the zip (onedrive). I'll try to help you – magicandre1981 Nov 5 '16 at 16:57
  • @magicandre1981 from the VM or his host? – Seth Nov 5 '16 at 20:40
  • from the system where you try to remove Hyper-V and get the "reverting changes" message after reboot – magicandre1981 Nov 6 '16 at 6:37
23

For others who have the same problem, but cant find a solution yet:

Probably you have some leftover internet adapters on your machine. (sometimes, they are disabled and not visible in the Hyper-V manager)

Go to your Network Center and see if you still have network adapters from the 'Hyper-V' kind. (you cant remove/delete them on right click)

To still get them off your system, go to: Properties > Configure > Driver Software (tab)

From there, choose 'Remove device'. Wait a little, and press F5 (refresh). Repeat this process until all network adapters of Hyper-V are gone.

Now try and uninstall Hyper-V again and see it work. (reason previous uninstall failure: unable to cleanly uninstall hyper-v, due uncontrolled dependencies)

  • Minor point: Under Windows 10, it's not 'Remove device' but 'Uninstall Device'. Same effect, though, and everything else works as printed on the box. – Dan Mar 26 '19 at 16:19
4

Remove all Hyper-V virtual network adapters/switches before disabling Hyper-V from optional features.

To remove virtual switches you setup use the appropriate dialog:

How to remove switches

  • Could you expand on it a bit? If you include some more information and how you came up with that solution it would certainly improve this answer. – Seth Jan 25 '17 at 6:54
  • @Seth I don't know if this answer is correct or not, but here is how you should remove switches: You need to open Hyper-V Manager and then do this: i.stack.imgur.com/N4cHJ.png. – user477799 Jan 25 '17 at 7:08
  • You uploaded that picture and made an edit. Why not just include the picture in the post? – Seth Jan 25 '17 at 8:37
  • So I am to believe that the reason the author was unable to remove Hyper-V is because they had a virtual Hyper-V network adapator installed? How did you conclude the author even has a virtual switch configured? – Ramhound Jan 25 '17 at 15:48
  • I'm saying that might be the solution, because in my case this turns out to be the problem. I actually had the virtual switches screwed up across insider preview updates, unable to find them in virtual switch configuration, so I had to uninstall them in device manager. – Norman Zhi Jan 26 '17 at 10:43
1

Check if you have inadvertently disabled a Hyper-V virtual switch in Control Panel\Network and Internet\Network Connections. If so, try removing it from device manager then disable Hyper-V.

  • Thanks for the answer. I have already solved this problem by freshly installing Windows – Jakob Abfalter Mar 16 '17 at 9:19
0

I had a similar issue where I could not install Intel(r) HAXM (Hardware Accelerated Execution Manager). I opened PowerShell in Administrator mode and ran this command: Disable-WindowsOptionalFeature -Online -FeatureName Microsoft-Hyper-V-All

for more info http://www.poweronplatforms.com/enable-disable-hyper-v-windows-10-8/

Not the answer you're looking for? Browse other questions tagged or ask your own question.