Update #1
1) Booted into Ubuntu Live CD
2) Connected drive using a SATA->USB converter
3) Very meaningful error message:

Error mounting: mount exited with exit code 13: $MFTMirr does not match $MFT (record 3).
Failed to mount '/dev/sdc2': Input/output error
NTFS is either inconsistent, or there is a hardware fault, or it's a SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows then reboot into Windows twice. The usage of the /f parameter is very important! If the device is a SoftRAID/FakeRAID then first activate it and mount a different device under the /dev/mapper/ directory, (e.g. /dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation for more details.

Maybe this is a RTFM-type situation, and I will look into exit code 13, but any assistance you can provide is appreciated.

Will look into R-STUDIO and RAID RECONSTRUCTOR/GetDataBack now as well

1) Had perfectly booting/functional Windows 7 setup using a RAID 1 array with 1 TB HD x 2 via AMD motherboard 780G chipset

The Mistake:
2) Temporarily removed both RAID drives, set BIOS back from RAID->IDE mode and worked on two other drives for different project
3) Replaced RAID drive and booted up, ** forgetting to re-enable RAID **
4) Used computer for 1 day...
5) Reset BIOS to IDE->RAID
6) Windows no longer booted. The default Windows 7 auto-fix tools were allowed to run several times. CHKDSK may have reported errors.

Data recovery attempt:
7) Removed one drive from RAID 1 array
8) Connected drive to Windows Vista laptop using a SATA->USB converter

I am able to read every partition on the drive and recover data, except for the partition with Win 7 installed

Error message: "g: drive is not accessible. Access is denied."

The drive IS visible in the Disk Management tool, and all paritions (including the inaccessible Win 7 partition) are reported to be healthy.

Does Windows 7 by default prevent access to its partition? (No, I did not enable BitLocker or any other NTFS security measure. Windows 7 was installed using all default options.)

I have also tried the other drive in the array with the same result.


It could be that Windows is respecting file ownership and permissions on that partition, i.e. ownership is set to a user that doesn't exist on the second Windows setup (its local system account probably) and so on.

You could try updating the ownership of the drive. In XP this would be done by right-clicking in Explorer, selecting properties, selecting the security tab, then selecting the owner tab. From there you can set the ownership flag to point to you. Click OK until you are back at "my computer" then go to the security properties again and give yourself read access to the drive. This sequence may differ slightly in Vista.

Another option is to plug the drive into a machine running an OS that doesn't neccesarily respect Windows ownership+perms and try to read the data from there. Perhaps you could try booting the Vista box using Knoppix of the Ubuntu LiveCD, plug the drive in via USB adaptor, and see if you can read the files that way. This has the advantage of not changing anything so you have greater chance of getting the OS on the drive working again in future without reinstalling.


The RAID controller may have overwritten the start of that partition with some information. I would get R-STUDIO and RAID RECONSTRUCTOR/GetDataBack and run those tools to see what they can recover.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy