8

I'm experiencing DNS issues on my Win 10 machine which are the following:

  • On system start-up, everything works just fine
  • After some time, DNS requests start to time-out
  • When requests are timed out, the issue either persists for some time and then it starts working again by itself for a brief period of time (after which the issue is cycling again) or it persists till I Disable / Enable my adapter (which fixes it immediately, again for a brief period of time)

More details:

It affects only DNS. Requests like ICMP or direct IP are just fine. If the connection is established and there is no need to request DNS again for it - it works without any issues for any period of time.

During the time when there is a DNS issue, I can observe the following:

C:\Users\almado>nslookup yahoo.com
DNS request timed out.
    timeout was 2 seconds.
Server:  UnKnown
Address:  8.8.8.8

DNS request timed out.
    timeout was 2 seconds.
Non-authoritative answer:
Name:    yahoo.com
Addresses:  2001:4998:58:c02::a9
          2001:4998:c:a06::2:4008
          2001:4998:44:204::a7
          98.138.253.109
          98.139.183.24
          206.190.36.45

and for the DNS server itself:

C:\Users\almado>nslookup
DNS request timed out.
    timeout was 2 seconds.
Default Server:  UnKnown
Address:  8.8.8.8

What I've already tried

  • Using another DNS server (from snippets above it's obvious I was using Google public DNS at that time). I've tried using ISP-provided DNS both statically and with automatic settings options in the IPv4 of my network adapter
  • Resetting all caches, releasing the address and renewing the lease. I've also reset the winsock catalog, the full listing would be:

    ipconfig /flushdns
    ipconfig /registerdns
    ipconfig /release
    ipconfig /renew
    netsh winsock reset catalog
    netsh int ipv4 reset reset.log
    netsh int ipv6 reset reset.log
    
  • Disabling smart name resolution / parallel requests. This is as it's described here. Important thing would be that the mentioned keys didn't exist and therefore I've added them
  • Disabling DNS Client Service (via services.msc). Disabling / enabling IPv6 in the network adapter options. These actions don't change anything.
  • Adding gpedit.msc console to the system manually (I have Home edition which doesn't have it by default) hoping to enable "Turn off smart multi-homed name resolution" there. But in the "Administrative Templates" > "Network" > "DNS Client" I do not have this option at all and more - all options which I have there have "Not configured" state.
  • Restoring default "Internet Settings". It's "Solution 5" from here.
  • Using anti-virus software to perform full scanning in case DNS is throttling me as I might have some malware. Nothing was found.

Of course I've rebooted the machine after mentioned modifications. It worth mentioning that the issues started to happen not long ago - same machine was working just fine without troubles and nothing was changed manually - but I believe issues started to occur after latest Windows update (not 100% sure about that).

I've also checked that it's not some firewall-related issues by disabling firewall completely and still observing same issue after some time.

Versions

  • System: x64
  • OS: Windows 10 Home 1607 / Build 14393.351

ipconfig /all (here I'm using my ISP LAN router as the DNS server)

Windows IP Configuration

   Host Name . . . . . . . . . . . . : Home
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : hitronhub.home

Ethernet adapter Ethernet:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
   Physical Address. . . . . . . . . : F0-79-59-81-96-65
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Local Area Connection* 3:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft Wi-Fi Direct Virtual Adapter
   Physical Address. . . . . . . . . : E8-B1-FC-6B-AC-75
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Ethernet adapter VPN - VPN Client:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : VPN Client Adapter - VPN
   Physical Address. . . . . . . . . : 00-AD-D0-34-8B-00
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter WiFi:

   Connection-specific DNS Suffix  . : hitronhub.home
   Description . . . . . . . . . . . : Intel(R) Dual Band Wireless-AC 7260
   Physical Address. . . . . . . . . : E8-B1-FC-6B-AC-74
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   IPv4 Address. . . . . . . . . . . : 192.168.0.10(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Wednesday, November 9, 2016 7:40:10 PM
   Lease Expires . . . . . . . . . . : Wednesday, November 16, 2016 7:40:09 PM
   Default Gateway . . . . . . . . . : 192.168.0.1
   DHCP Server . . . . . . . . . . . : 192.168.0.1
   DNS Servers . . . . . . . . . . . : 192.168.0.1
   NetBIOS over Tcpip. . . . . . . . : Enabled
  • You are obviously using Google's public DNS server, so have you already tried utilizing a different source for DNS resolution to see if the problem persists? – Run5k Nov 6 '16 at 23:33
  • Yes, I've tried ISP-provided DNS both statically and with automatic settings resolution (in the adapter settings for IPv4). – Alma Do Nov 6 '16 at 23:34
  • I assumed that you had probably already done that. It may be a good idea to edit your question and add that information to your section titled What I've already tried. – Run5k Nov 6 '16 at 23:51
  • Indeed. I've also thought it was an obvious thing. – Alma Do Nov 6 '16 at 23:56
  • Google's DNS will throttle you for too many queries over time. Check for malware. – Tyson Nov 7 '16 at 1:09
3
+100

This answer summarizes the research done by the poster and myself to analyze and fix the problem.

I describe here the sequence of actions that will (probably) fix the problem, followed by my theory why it works.

Step 1 : Stop the the DNS Client service

  1. In the Start Menu of Windows, type services and click to run on Services
  2. Find the service named DNS Client
  3. Right-click the service and do Stop to stop it

Step 2 : Do network reset

  1. In the Start Menu of Windows, click on Settings
  2. Click on Network & Internet
  3. Click on Status
  4. Click Network reset
  5. Click Yes

A detailed description can be found in this article. I believe that Network reset is probably equivalent to doing all the re-initialization commands listed above in the post.

Step 3 : Restart the DNS Client service

Repeat Step 1, but do Start instead to restart the service.
If the problem still occurs, try to reboot Windows.

My theory as to why it works

Apparently some bad setting related to the DNS Client service was introduced into Windows, which caused DNS to malfunction. Network reset is normally sufficient to bring the network to a known state, but in this case the bad setting could not be reset while the service was running. So the DNS Client service needed to be stopped for the Network reset to successfully reinitialize all the DNS settings.

  • Now, I can't up-vote the answer since all my rep. went to a bounty, but I hope accepting it would be enough. – Alma Do Nov 10 '16 at 14:51
  • Thanks. I up-voted the post for starting on future reputation. – harrymc Nov 10 '16 at 15:06
  • For some reason, Win really wants the service to run. Every time it starts (I guess OS is starting it for some reason), I have a huge network lag and then the problem starts to appear again until I reset the network (so the solution from your post works again and again). For now I've set the service status to "disabled" hoping it will never be launched again, but questions would be: what if it still will be launched, how to forcefully disable it at all? And, if not - is it fine to disable this service, could it harm the system somehow? – Alma Do Nov 11 '16 at 23:31
  • Some Windows software uses the DNS Client service, for example ping. Other, such as nslookup, issues a DNS query to the network without using it. Browsers usually fall in the later case. This service holds a DNS cache, but so usually does the router. If all utilities that you use work correctly without it, including Windows Update, you can leave it disabled. If not, you could re-enable it and use a startup script to restart it (you wouldn't be the first). – harrymc Nov 12 '16 at 7:24
0

Had same issue,

from what I have tested and read, you cant disable smart name resolution and parallel requests through registry in Windows 10, these registry edits refer to Windows 8 only.

You need to enable "Turn off smart multi-homed name resolution" in Group Policy Editor (gpedit.msc)

As you have home version, you need to manually install policy editor first, takes little tweaking.

  • Curious. I've added gpedit.msc manually without an issue. Now I'm following instruction for enabling this "Turn off smart multi-homed name resolution" and.. well, it's absent where it should be (Administrative Templates > Network > DNS Client). What would it mean? (More, I have all entries there as "Not configured") – Alma Do Nov 8 '16 at 22:31
  • not configured is default state, if its not set up – Batchman Nov 9 '16 at 17:57
  • So, why I don't have the mentioned option in gpedit.msc? Could it be because I've installed an "artificial" one, not MS-provided? – Alma Do Nov 9 '16 at 18:41
  • looks like ms does not allow home version users to turn it off – Batchman Nov 9 '16 at 21:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.