My cat sat on my laptop and now if I type either L or P, it inputs 3 or * instead. The rest of my keyboard still works correctly. The problem is bad enough that I had to use the touch screen of my computer to type this in.

How can I restore the correct working behaviour of my keyboard?

  • 25
    Take the animal off the keyboard! – TaW Nov 12 '16 at 11:54
  • 15
    @MateenUlhaq The internet really loves cats. It's a mystery. – T.C. Proctor Nov 12 '16 at 15:33
  • 6
    are you sure he simply sat there? – Sarge Borsch Nov 12 '16 at 20:41
  • 39
    Try turning off cat-lock. – Owen Nov 13 '16 at 16:58

That's the standard tenkeyless Num Lock key layout found on many PCs.

Picture of tenkeyless Num Lock key layout on a keyboard

Turn off Num Lock - on my Lenovo, it's Fn + F10, but the combination may vary by manufacturer.

  • 73
    It's actually not a proper NumLock, despite sharing the name. It's a separate function to activate the keypad. NumLock proper changes the function of the keypad itself, regardless of whether the keypad is embedded and separately activated (like this one) or a proper independent keypad. With NumLock turned off the keypad becomes a set of directional arrows with PgUp, PgDn, Home, End, etc. – J... Nov 7 '16 at 14:47
  • 2
    Huh. I didn't know there was an option to lock that; I thought you always had to hold a button down to get the numpad functionality. – user2357112 Nov 7 '16 at 22:23
  • 4
    IIRC on at least some laptops it shares more than just the name, I.E. if you plug in an external keyboard and press the numlock key on the external keyboard then the function of they keys on the internal keyboard change from regular letter keys to "embedded numpad" keys. – plugwash Nov 8 '16 at 3:03
  • @plugwash Yes, I've "broken" my wife's Fujitsu this way, using the real NumLock on external kb. – Agent_L Nov 9 '16 at 12:21
  • 7
    With several keyboard microcontrollers it is exactly proper NumLock. Such microcontrollers switch amongst four possible sets of mappings according to the current states of the Fn key and the host's NumLock LED output. – JdeBP Nov 10 '16 at 9:26

You need to turn off Num Lock and it will work as expected again.

On my ASUS laptop the key combination is Fn + Insert.

Your keyboard is now set to be the numeric pad; this is accomplished with a Fn key press plus another key, which varies by manufacturer. The proof to this is to check the other keys: O, I, K, M, N, J.

If they also produce numeric keypad numbers, then, you need to press the Fn key combination again to toggle off the keyboard numeric keypad.

If they do NOT produce the keypad numbers, then your keyboard is broken. Use a paperclip and scoop out that dingleberry from underneath the L and P keys, and banish the cat from future use of your laptop.

On Windows, Alt + Shift toggles key mapping on and off. Your cat could have hit those keys when using your keyboard as its personal cushion.

Press Alt + Shift again to restore standard keyboard behavior.

  • I guess remove the question marks and rephrase it as as a statement and it should be fine. Looks like the content of the answer is okay though. This is like jeopardy in reverse. – Julian Cienfuegos Nov 11 '16 at 18:22
  • It needs more than a cosmetic brush-up to answer the question, "How can I fix this?" – Scott Nov 11 '16 at 19:38
  • 2
    @Scott A partial answer is still an answer. In fact, in some cases, this might be enough to fix the problem – jpaugh Nov 12 '16 at 2:28

protected by Community Nov 13 '16 at 4:48

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.