6

After my Win7 got broken recently I decided it is finally the time to upgrade to Win10. I (it seems like many others) hate blurry fonts configured in Win7+ and had clear-type and smoothing disabled in Win7. I'm trying to replicate the same in Win10, but can't make it work completely.

The result I have so far is on this picture ('OK' areas are green, 'bad' areas are red): Partially-substitured-fonts

Steps i've done

  • Uncheck : SystemPropertiesAdvanced.exe -> Performance -> Settings -> Smooth Edges of screen fonts
  • Uncheck 'Turn on ClearType' in "Adjust ClearType text"
  • Apply registry script to replace "Segoe UI" with "Tahoma" (because 'Segoe' without smoothig is extremly ugly)

The result I currently have is somewhat strange:

  • In Google Chrome - everything is OK except hover-tooltips
  • Windows Explorer is mostly OK except context menues
  • Windows Taskbar - is all blurry :(
  • Windows Task Manager - Titlebar, top menu and status line - OK, everything else is blurry

So it seems I'm missing some small thing, but can't catch it. Any ideas what is missing?

Note: At some early stage of experiments I had state when "Task bar" did use correct substituted fonts and without smoothing (as well as Task Manager was completely OK), but at the same time tabs in Google Chrome were blurry. Taskbar got borken while fixing Chrome - at that time i was experimenting with WinaeroTweaker application and I have no idea what it did to registry. Unfortuantelly i could not make Taskbar to be non-blurry again even after one-more fresh reinstall of Win10.

Registry script:

REGEDIT4

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontSubstitutes]
"MS Shell Dlg"="MS Sans Serif"
"MS Shell Dlg 2"="MS Sans Serif"
"Segoe UI"="Tahoma"
"Segoe UI (TrueType)"="Tahoma"
"Segoe UI Black"="Tahoma"
"Segoe UI Black (TrueType)"="Tahoma"
"Segoe UI Black Italic (TrueType)"="Tahoma"
"Segoe UI Bold (TrueType)"="Tahoma"
"Segoe UI Bold Italic (TrueType)"="Tahoma"
"Segoe UI Historic (TrueType)"="Tahoma"
"Segoe UI Italic (TrueType)"="Tahoma"
"Segoe UI Light"="Tahoma"
"Segoe UI Light (TrueType)"="Tahoma"
"Segoe UI Light Italic (TrueType)"="Tahoma"
"Segoe UI Semibold"="Tahoma"
"Segoe UI Semibold (TrueType)"="Tahoma"
"Segoe UI Semibold Italic (TrueType)"="Tahoma"
"Segoe UI Semilight"="Tahoma"
"Segoe UI Semilight (TrueType)"="Tahoma"
"Segoe UI Semilight Italic (TrueType)"="Tahoma"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts]
"Segoe UI (TrueType)"=-
"Segoe UI Black (TrueType)"=-
"Segoe UI Black Italic (TrueType)"=-
"Segoe UI Bold (TrueType)"=-
"Segoe UI Bold Italic (TrueType)"=-
"Segoe UI Italic (TrueType)"=-
"Segoe UI Light (TrueType)"=-
"Segoe UI Light Italic (TrueType)"=-
"Segoe UI Semibold (TrueType)"=-
"Segoe UI Semibold Italic (TrueType)"=-
"Segoe UI Semilight (TrueType)"=-
"Segoe UI Semilight Italic (TrueType)"=-


[HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Common]
"RespectSystemFontSmooth"=dword:00000001

; 
[HKEY_CURRENT_USER\Control Panel\Desktop]
"FontSmoothing"="0"
"FontSmoothingType"=dword:00000000

[HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics]
"CaptionFont"=hex:f3,ff,ff,ff,00,00,00,00,00,00,00,00,00,00,00,00,90,01,00,00,\
  00,00,00,cc,00,00,00,00,54,00,61,00,68,00,6f,00,6d,00,61,00,00,00,00,00,00,\
  00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
  00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00
"IconFont"=hex:f5,ff,ff,ff,00,00,00,00,00,00,00,00,00,00,00,00,90,01,00,00,\
  00,00,00,cc,00,00,00,00,54,00,61,00,68,00,6f,00,6d,00,61,00,00,00,00,00,00,\
  00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
  00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00
"MenuFont"=hex:f4,ff,ff,ff,00,00,00,00,00,00,00,00,00,00,00,00,90,01,00,00,\
  00,00,00,cc,00,00,00,00,54,00,61,00,68,00,6f,00,6d,00,61,00,00,00,00,00,00,\
  00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
  00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00
"MessageFont"=hex:f5,ff,ff,ff,00,00,00,00,00,00,00,00,00,00,00,00,90,01,00,00,\
  00,00,00,cc,00,00,00,00,54,00,61,00,68,00,6f,00,6d,00,61,00,00,00,00,00,00,\
  00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
  00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00
"SmCaptionFont"=hex:f3,ff,ff,ff,00,00,00,00,00,00,00,00,00,00,00,00,90,01,00,\
  00,00,00,00,cc,00,00,00,00,54,00,61,00,68,00,6f,00,6d,00,61,00,00,00,00,00,\
  00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
  00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00
"StatusFont"=hex:f5,ff,ff,ff,00,00,00,00,00,00,00,00,00,00,00,00,90,01,00,00,\
  00,00,00,cc,00,00,00,00,54,00,61,00,68,00,6f,00,6d,00,61,00,00,00,00,00,00,\
  00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\
  00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00
2

After digging more into this problem I've finally found the solution. There 2 problems:

  1. Original 'reg' script I've took somewhere from internet had "MS Sans Serif" as target font. I've changed it Tahoma because "MS Sans Serif" seems to be too small.
  2. It looks like different windows in MS applications have different font setting and therefore TrueType font are being smoothed in one places and not-smoothed in other places. Raster fonts (which "MS Sans Serif" is) are not smoothed in these 'wrong windows' when font-smoothing is not enabled.

Therefore solution will work only when substituting Segoe UI with some raster font. This however has adverse effect - large characters look ugly (what occurs rather rarelly and therefire is of less inconvinience to me than global blurriness):

enter image description here

Workable font-substitues are following:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontSubstitutes]
"MS Shell Dlg 2"="MS Sans Serif"
"MS Shell Dlg"="MS Sans Serif"
"Segoe UI"="MS Sans Serif"
"Segoe UI Light"="MS Sans Serif"
"Segoe UI Semibold"="MS Sans Serif"
"Segoe UI Symbol"="MS Sans Serif"
"Segoe UI (TrueType)"="MS Sans Serif"
"Segoe UI Bold (TrueType)"="MS Sans Serif"
"Segoe UI Bold Italic (TrueType)"="MS Sans Serif"
"Segoe UI Italic (TrueType)"="MS Sans Serif"
| improve this answer | |
  • 2
    This is great! This has been the closest I've come to be able to eradicate font-smoothing in Windows 10. However, there are still some areas like the Task Menu and Notification slide-out that still have the blurry text: i.imgur.com/bp5WGDi.png Have you come up with any ways to remove font smoothing on the TaskBar menus? Also, WPF apps still have blurry text. Like going to the settings icon, fonts still seem to have smoothing. – Brian Chavez Mar 24 '18 at 20:46
  • 1
    At 2020 - the problem still exists :( For me it's strange how the hell millions of people are using / suffering from those blurry fonts.. And silence, silence.. Can not find any solution how to fix blurry Taskbar text, Desktop menus, some File Chooser elements.. (using Tahoma as system font) – Ernestas Gruodis Apr 24 at 22:14
-1

Make sure you have the windows update component enabled. Go to Start > Settings (or PC settings if you use Classic shell) > Apps & features > Manage Optional Features, hit Add a feature > download the "Korean supplemental Fonts" once that has finished, run the registry files that's been provided, except replace "MS Sans Serif" with "Dotum"

The Dotum font is not a raster font (also known as a bitmap font) and is the closest I've found to Tahoma. I really hope someone finds a better solution or font because aliased fonts are bad for your eyes long term.

| improve this answer | |
  • This answer is not applicable to the version of Windows 10 the author was using. You could not install fonts on Windows 10 using your described method in 2016 when this question was asked. – Ramhound Jan 19 '19 at 3:59
  • Thanks for idea ... just got chance to check it with new installation of Windows. Unfortunately it is not OK for me - it has awful rendering for Cyrillic symbols. And it also seems a bit larger higher than MS Sans Serif and therefore does not nicely fit in some places ... – Xtra Coder Feb 4 '19 at 12:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.