2

I have just installed Arch Linux in my laptop.

I have awesome window manager, and I can start it from the tty with startx. When I install GDM (as I would like to have my computer start directly from GUI with a conventional login screen) and systemctl enable gdm.service + reboot and enter my password, the screen will turn black for some seconds and will return me to the login screen. Every time.

I have copied .Xauthority from my root folder to my user one and chowned it, created the files as seen here, purged the packages and reinstalling; but nothing works.

HOW TO REPRODUCE:

  1. Fresh Arch Linux install from LiveCD.
  2. Create your user + password.
  3. pacman -S gdm gnome
  4. systemctl enable gdm.service
  5. pacman -S awesome
  6. Add 'exec awesome' to .xinitrc.

At this point you should be able to startx to get to Awesome. After a reboot, the login screen will appear and you should be facing my error.

EXTRA INFO:

I have tried LightDM and it works perfectly, but the GNOME issue still bugs me and I want to solve it ASAP. I am attaching my logs:

  1. JOUNALCTL -E -U GDM

[Basically starts normally, but says my display lasted for a bit more than a second]

  1. DMESG

gnome-session-f[747]: segfault at 0 ip 00007f3d4eb1e5c9 sp 00007ffcdd40df00 error 4 in libgtk-3.so.0.2200.2[7f3d4e83c000+6f3000]

  • use lightdm or post any error message. – Ipor Sircer Nov 8 '16 at 22:01
0

A fresh new install of Arch Linux following the official guide will solve the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.