4

I'm having an intermittent issue where I get purple artefacting in my RDP session.

Artifacting

The RDP is to a local Hyper-V machine which is configured to use RemoteFX. I have a nVidia GTX 970 with the latest drivers (375.70)

This is my RDP configuration

screen mode id:i:2
use multimon:i:1
desktopwidth:i:1920
desktopheight:i:1200
session bpp:i:32
winposstr:s:0,1,608,165,1408,765
compression:i:0
keyboardhook:i:2
audiocapturemode:i:0
videoplaybackmode:i:1
connection type:i:6
networkautodetect:i:0
bandwidthautodetect:i:1
displayconnectionbar:i:1
enableworkspacereconnect:i:0
disable wallpaper:i:0
allow font smoothing:i:1
allow desktop composition:i:1
disable full window drag:i:0
disable menu anims:i:0
disable themes:i:0
disable cursor setting:i:0
bitmapcachepersistenable:i:0
full address:s:win10-dev-vm
audiomode:i:0
redirectprinters:i:0
redirectcomports:i:0
redirectsmartcards:i:1
redirectclipboard:i:1
redirectposdevices:i:0
drivestoredirect:s:R:\;
autoreconnection enabled:i:1
authentication level:i:2
prompt for credentials:i:0
negotiate security layer:i:1
remoteapplicationmode:i:0
alternate shell:s:
shell working directory:s:
gatewayhostname:s:
gatewayusagemethod:i:4
gatewaycredentialssource:i:4
gatewayprofileusagemethod:i:0
promptcredentialonce:i:0
use redirection server name:i:0
rdgiskdcproxy:i:0
kdcproxyname:s:
gatewaybrokeringtype:i:0
devicestoredirect:s:*

If I close the RDP sessions and re-open it, the artefacts goes away for a while but then comes back.

Has anyone seen this before or got any thoughts about how to resolve it.

  • What OS are both client and server? – cdavid Nov 9 '16 at 1:04
  • Both are Windows 10 Pro – Alastair Pitts Nov 9 '16 at 1:37
6

On the client machine:

Can you please open gpedit.msc and then navigate to Computer Configuration -> Administrative Templates -> Windows Components -> Remote Desktop Services -> Remote Desktop Connection Client and then on the right hand side there should be a setting Do not allow hardware accelerated decoding - please double click and enable that setting, apply and restart the remote desktop client.

Background - this is an active bug already captured via the feedback tool and being worked on for the next release of Windows 10 (Creator's Update).

2

This looks hardware decoding problem. Have you tried disabling hardware accelerated decoding on the RDP client machine? The Group Policy setting is available under the "Computer Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Connection Client".

0

The group policy setting sets the following registry key:

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services\Client]
"EnableHardwareMode"=dword:00000000
0

If disabling "hardware accelerated decoding" fails in solving this problem on Win10 try with deleting cached files at:

C:\Users\%UserName%\AppData\Local\Microsoft\Terminal Server Client\Cache

on client machine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.