The title is sufficient I think. How can I stop Fedora to automatically download and install system and software updates on restart?

up vote 6 down vote accepted

dnf is a background service that updates the repository metadata automatically. dnf makecache is scheduled to run after every reboot

To disable dnf-makecache.service:

systemctl disable dnf-makecache.service 

Also disable the dnf-makecache.timer or the service will be restarted:

systemctl disable dnf-makecache.timer

Regards

  • Thank you, I've accepted the answer. I just wonder if commands are the only option to disable updates on Fedora 25, is it possible through editing configuration files as well? – w17t Nov 9 '16 at 11:46
  • 6
    Note that you also will need to separately disable packagekit refreshes. This is a known problem and I'm optimistic that we'll get this solved in the next release (but not F25). gsettings set org.gnome.software download-updates false – mattdm Nov 9 '16 at 15:14
  • 1
    the mattdm comment has to be in the answer, seems to be the obligatory piece of the puzzle as everything else was kinda disabled – MolbOrg Apr 10 '17 at 16:19
  • Even after setting download-updates=false in gsettings, it's downloading huge metadata files which is very very annoying. I'm trying to use fedora after long time Ubuntu and this reminded me why I chose ubuntu first. – Anwar Jul 18 '17 at 4:52

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.