9

I have a Dell Precision laptop running the latest version of Windows 10. I'm experiencing problems with my display settings where it sometimes won't recognize new displays connected via HDMI. When my laptop is not connected to any external displays and I go to Display settings, there are four extra displays shown, all grayed out and disabled.

I don't know what they are or why they are there. Is there any way to remove these? Or is there a way to reset all display configurations?

enter image description here

3

Try solution mentioned on https://answers.microsoft.com/en-us/windows/forum/windows_10-performance/windows-10-multiple-non-existent-screens/541f1815-de00-47a2-b638-5c0a6fdb01a4 that helped me.

It seems to be an issue in the Intel HD Graphics driver. Installing previous version, more specifically 15.40.4.64.4256 (https://downloadcenter.intel.com/download/25150/Intel-Iris-Iris-Pro-and-HD-Graphics-Production-Driver-for-Windows-10-64-bit) solves it for me, until someone will come up with better idea.

  • This solved it. Although it seems like a backwards solution to install an older driver. I tried reinstalling the latest driver after installing the older driver, only for the problem to reappear. Hopefully a future driver update will get it right again. – Daniel Nov 14 '16 at 9:22
  • 2018 here... I got this problem as well :/ – Yogurtu Aug 29 '18 at 4:18
  • @Yogurtu: Did you try reverting Intel GPU driver or other drivers for other GPUs you might have? – hysterical Oct 3 '18 at 16:41
  • In my case, I have a nvidia gtx 560, it seems to fail if I install latest nvidia drivers, but if I remove and reinstall with older version, it works fine, so basically the solution when you have an old video card, is to use old drivers. – Yogurtu Nov 16 '18 at 21:16
2

This is how I solved it on my Windows 10:

On the desktop, Right click > Display Settings > Under "Select and rearrange displays" click "identify" - Take note of the numbers that appear on your monitors. Those are you, valid monitors.

Select one of the "invalid" or "ghost" monitors. Scroll down and click the multiple display drop down. Select "Disconnect this display" and accept the change when prompted. Then click "Remove this display" from the same drop down.

Repeat this for each monitor you wish to remove, the display should go away.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.