1

I really need some help about my system freezing. Regardless of my Linux distribution (Ubuntu, Manjaro, ...) my system completely freeze.
It means that :

  • my mouse doesn't move
  • seconds in the clock doesn't change
  • can't connect to ssh
  • Ctrl+Alt+Fx doesn't work
  • Magic SysRq key sequences doesn't work

I only can shutting down by holding power button or unplug my PC.

This is my "sudo lspci" command result (sorry it's in french) :

Architecture :        x86_64
Mode(s) opératoire(s) des processeurs : 32-bit, 64-bit
Boutisme :            Little Endian
Processeur(s) :       4
Liste de processeur(s) en ligne : 0-3
Thread(s) par cœur : 1
Cœur(s) par socket : 4
Socket(s) :           1
Nœud(s) NUMA :       1
Identifiant constructeur : GenuineIntel
Famille de processeur : 6
Modèle :             55
Nom de modèle :      Intel(R) Pentium(R) CPU  N3520  @ 2.16GHz
Révision :           3
Vitesse du processeur en MHz : 1040.683
Vitesse maximale du processeur en MHz : 2415,7000
Vitesse minimale du processeur en MHz : 499,8000
BogoMIPS :            4328.66
Virtualisation :      VT-x
Cache L1d :           24K
Cache L1i :           32K
Cache L2 :            1024K
Nœud NUMA 0 de processeur(s) : 0-3
Flags:                 fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 movbe popcnt tsc_deadline_timer rdrand lahf_lm 3dnowprefetch ida arat epb dtherm tpr_shadow vnmi flexpriority ept vpid tsc_adjust smep erms

If you need some informations please ask me (specifying what command to run).
I have this computer from several years, but this problem has started from about 6 months. It's really troublesome now.
I'm actually under Manjaro (ArchLinux).
Please I need to resolve that and I can't work under Windows. Thanks beforehand.

Edit : Solved !

  • It can't be a hardware problem? – Ipor Sircer Nov 9 '16 at 16:17
  • @IporSircer Maybe the Graphical Card ? But it never done that under Windows. – Raphael T. Nov 9 '16 at 16:23
  • You've said that you're using this system for years. If there was no problem before 6 months, then it's not a sw problem. If you're using linux only for 6months, it can be true. Video drivers are (almost) always low quality in linux. Make a try in vesa mode. – Ipor Sircer Nov 9 '16 at 16:30
  • @IporSircer Sorry I run under Ubuntu since I have this PC, in dual-boot and I change for Manjaro last month. Freezes appeared (approximatively) from 6 months ago. Can you explain the vesa mode please ? – Raphael T. Nov 9 '16 at 16:40
  • remove xserver-xorg-video-intel package, then xorg will use vesa mode. (it's slow) – Ipor Sircer Nov 9 '16 at 16:43
0

Solution :
I finally fixed the problem ! This is my solution :

  1. Boot on live linux system from USB or CD, the system you choose has to have GParted installed
  2. Open GParted
  3. Select your HDD (/dev/sda for me)
  4. Right click on your linux filesystem partition (/dev/sda4 for me)
  5. Click on "Check" or "Vérifier" in french, partition has to be unmounted, this is why you need to boot from live system
  6. Let the script work, it will repair your filesystem
  7. When it's done just reboot normally

It worked for me !

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.