I cannot reach my http server that runs on windows machine (host) from the ubuntu that runs on vmware virtual machine (guest).

I have set up the host listening on http://HOST_IP:1500 and can see that it responds in local. But, cannot do the same on guest machine, the page always returns taking too long to respond error.

I have Bridged network setup on vmware & can ping to the HOST_IP. I can even send TCP/IP packages from another program between two machines. I have tried other ports like 8080, 2016, 3000 etc.

I cannot see what the problem is, and appreciate any help. Thank you.


I have solved the problem with following settings: 1. Bridged connection to "Vmware1 & manually set network connections on ubuntu (IPv4 settings) 2. Check for the proxy settings of ubuntu & the web browser ( I have disabled proxy usage for all network)

  • Consider adding a blank line in order to have your list format as a list. You should be able to mark your own answer as a solution if I'm not mistaken. – Seth Nov 10 '16 at 9:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.