0

I was using Ubuntu alongside Windows 10 on internal HDD. I've just got a new SSD, then I copied my ubuntu to SSD with rsync command with connecting this SSD externally. Then I removed the internal HDD from PC (which includes win10 and ubuntu) then connected SSD internally(which includes only ubuntu). After repairing grub, internal ubuntu has worked.

But connecting the HDD externally and trying to boot windows on it gave me "inaccesible boot device" error. I've tried to solve it using both windows cmd(accessed from safe mode) and ubuntu boot-repair tool.

In boot-repair program, I couldn't select 'MBR' option which was greyed out. Repairing grub of ubuntu of external HDD worked for external ubuntu, but selecting Windows on that grub again ended up with the same 'inaccesible boot device' error.

In cmd of windows(tried with both windows setup disk cmd and safe mode cmd), I've run some bootrec commands which did not help as well.

I've given up my old files and tried to run a clean win10 installation on external HDD, which I recognized that it was about to install it on internal SSD.

Can I simply fix windows boot manager and keep my windows externally?

1

1 Answer 1

0

I think you need to format that external drive as "bootable" in order to create the MBR so you can boot from it.

Steps by steps can be found here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.