14

I have a Windows 10 laptop, running OS version 1607 and with all latest updates installed. I routinely use the mobile hotspot feature to share the Ethernet connection with WI-FI devices, and I find that quite often the function just turns off on its own after a while.

I have disabled automatic standby and/or hibernation, both when running on battery and when running on mains power; BTW, this is an office setting: the computer is always connected both to power and Ethernet.

The issue seems to be related to screen timeout; the mobile hostspot feature doesn't turn off if I manually lock the screen (Windows-L), but it does when the screen turns off due to timeout (regardless of whether it's already locked or not). This seems also to be a common issue on Windows 10 phones, where the exact same thing happens when the phone screen auto-locks.

Why does this happen, and how can I fix it (other than always leaving the screen turned on, which is something I'd like to avoid)?

  • Do you have a device connected when mobile hotspot ("share my connection with other devices") turns off? – user598527 Nov 19 '16 at 19:48
  • 1
    Try this youtu.be/SfWazCPo44w – tMJ Jan 2 '17 at 17:57
  • @tMJ That is helpful – NVZ Apr 24 '17 at 8:29
  • @tMJ That's exactly what I was going to suggest, but instead, I was thinking it may be the hard disk shutting down.. – var firstName Jun 30 '17 at 17:39
3

There are two ways of fixing this, as behind the scenes its just creating a hostednetwork. Microsoft is constantly changing its windows 10 OS and barley has documentation of its features so this might not work on your specific Windows 10 version.

1. Registry fix

There is a registry setting that determines this. Unfortunately at the time of the writing you can only increase the timeout to 120mins.

Increase WiFi Mobile Hotspot no clients timeout:

  • The time-out period, in minutes, after which Internet sharing should automatically turn off if there are no longer any active clients. This node can be set to any value between 1 and 120 inclusive. A value of 0 is not supported. The default value is 5 minutes.+ A reboot may be required before changes to this node take effect.

HKLM\System\ControlSet001\Services\ICSSVC\Settings\PeerlessTimeout

Increase WiFi Mobile Hotspot no internet connection timeout:

  • The time-out value, in minutes, after which Internet sharing is automatically turned off if a cellular connection is not available. This node can be set to any value between 1 and 60 inclusive. The default value is 20 minutes. A time-out is required, so a value of 0 is not supported. Changes to this node require a reboot.

HKLM\System\ControlSet001\Services\ICSSVC\Settings\PublicConnectionTimeout

2. Install Windows Configuration Designer and change the setting

  • On devices running Windows 10, you can install the Windows Configuration Designer app from the Microsoft Store. To run Windows Configuration Designer on other operating systems or in languages other than English, install it from the Windows Assessment and Deployment Kit (ADK) for Windows 10.
  • After creating a profile for all versions of windows search for hotspot. You can change the settings here. Here is some documentation for it. It says that it only works on the mobile version but thats not true. I was able to apply the mobile cofigureation settings on my windows 10 x64 pro Fall-Creators-Update version.
  • After updating to Windows 10 version 1809, the registry PeerlessTimeout doesn't seem to work anymore. – Duc Nguyen Dec 19 '18 at 3:15
  • 1
    Thanks for the update. I'm thinking about adding a bounty to this question to get some better answers. I also need uninterrupted tethering. – Gabriel Fair Dec 20 '18 at 13:24
  • Also, PeerlessTimeout is not available in 1709 – z2z Jan 4 at 10:13
  • It might not be in the registry but windows might still respond to it if it was added. Could you try adding the registry key? I suspect it should be a DWORD 32 bit decimal – Gabriel Fair Jan 5 at 11:32
0

find your wifi adapter
open properties/configure
go to "Power Management" tab
uncheck "Allow the computer to turn off this device to save power"

(you may have to do so on other network adapters if you have more you're using)

-1

You need to go into power saving mode in the System Control panel, change the settings so the that screen saver does not shut down the system, but will shut down the display. You can turn of the screen but not the system. I would post the steps but I don't have my laptop in with me.

UPDATE: enter image description here

When you go into Change Advanced Power Settings make sure the Wifi is set for Max Performance.

  • 1
    Wrong. My system is already configured to not shut down/hybernate. The problem is about the WI-FI hotspot turning off, while the system remains fully operational. – Massimo Jul 29 '17 at 15:24
  • See my updates, you are not following my instructions. Check your settings. Post what they are if you are still having issues. – htm11h Jul 31 '17 at 12:49
-3

If you have any kind of virtual network adapters (e.g. from having VirtualBox or VMware installed), then disable the virtual adapters and the hotspot will stay on.

  • 1
    Welcome to Super User. This is a rant and not an answer to the question. – Glorfindel Aug 12 '17 at 20:57
  • Welcome to Super User! I've edited your answer to refine it down into a direct answer. For an intro to our site, please see the tour. – Ben N Aug 12 '17 at 21:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.