0

My friend has a SuperMicro server where the RAID controller all of a sudden seems to be broken (after a shutdown, drive swap, and startup). It shows "RAID Adapter Memory Error!!! Please check the SDRAM connection." The memory is onboard, so there is nothing I can do about that apparently. I tried everything to diagnose it, unplugged drives, even removed the riser board and plugged the RAID controller straight into the main board, no luck, same error.

I tried to locate an exact same RAID controller (LSI 350-8ELP) secondhand, but seems very difficult. I will try finding another LSI RAID controller (not exactly same type) and see if that works, but before I do that, since he does not have a recent backup, I want to make an image of each of the four hdd's (that were in RAID5) separately, just to have something (that could be used by a disaster recovery service should things really turn bad).

I attached an empty drive (to store the images) to my pc, along with the first of the RAID drives. I booted with Clonezilla Live (from USB), chose "dd" as way to copy, but as soon as the cloning should actually start, it says "No input device". I tried a few Clonezilla versions including the very latest but no luck.

Then I thought, let me run Ghost32 from within Windows, and clone them that way. But Windows sees a RAID5 member drive as an unpartitioned drive, and asks me if I want MBR or GPT for that drive. I don't want anything to be written to that drive, obviously, so I pressed Cancel. But then Ghost32 also doesn't want to allow that drive to be used as a source.

Would anyone know what is the best way to make raw images of that drive? Or even better, is there a way to access the RAID5 without the RAID controller?

Thanks. Life is really tough sometimes...

PS. I found this, but the replies are not specific enough, for example don't deal with the MBR question issue for Ghost32: Cloning HDDs from a hardware RAID array?

0

I found an answer to my own question.

Clonezilla won't work ("No input device!" error) when trying to clone a drive from the RAID5 set most likely because Clonezilla expects at least some MBR or GPT to be there, even when one selects dd as cloning tool. Because in clonezilla.log the last entry is "Searching for data/swap/extended partition(s)".

So I went into a linux command prompt on the Clonezilla Live CD, and started cloning to an image using "dd". The commands I used (had to google a bit):

mkdir /media/img    # a mount point to store the images
sudo mount /dev/sda1 /media/img   #/the drive where I'm writing the images to
sudo dd if=/dev/sdb conv=sync,noerror bs=64K status=progress >/media/img/xxx   #/dev/sdb is the drive to be cloned, xxx is the name of the image

Repeating that for every drive in the RAID should give me an exact image of each one.

The next step will now be to try to convert a Dell PERC 5i (in an old PowerEdge 2900 that I had lying around) into an LSI MegaRAID SAS 8480E by flashing it with that firmware, and then hope and pray that it will import the existing RAID5 when I insert those drives in it... If it does, install ESXi on it, and my friend should be back in business. If there are no more surprises.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.