0

I'm having an issue with an HP laptop that I just purchased. The network adapter is the Intel Dual Band Wireless-AC 8265.

The issue I'm having is that when I boot the computer, the network adapter does not automatically connect to my home network that is not broadcasting its SSID. If I display the SSID, everything works as it should; however, I need to have the SSID hidden. With the SSID hidden, if I boot the computer and do not have a connection, I can close the laptop lid, reopen it, and I will have a connection to the network.

Currently, I am running the latest driver offered by HP (Intel Wireless LAN Drivers v19.1.0.4 Rev.P, 205.1 MB, Aug 1, 2016). Since I was having issues with the driver that was included with the laptop, I decided to upgrade to this one, but that obviously didn't solve the problem. I also tried the driver offered by Intel, which also didn't work, so I decided to stick with the HP driver as I've heard that network connectivity issues tend get solved with HP's own drivers.

I am open to suggestions with trying different solutions to get it work as it should. However, if that's not possible, I was hoping someone could help me out with a temporary fix. Is there a shell command(s) that can be run that does to the network adapter whatever closing and opening the lid does? I was thinking I could make a script out of that and have it run automatically on startup.

EDIT: As I do more troubleshooting, I realize that the wireless connection does not work when I reboot the laptop, regardless of whether or not it was working when I rebooted. If I "Shut Down" and then turn on the laptop, the wireless connection works.

  • Just to double-check, when you configured the connection to your home network did you ensure that you checked the box to "Connect even if the network is not broadcasting" for a hidden SSID? – Run5k Nov 11 '16 at 17:42
  • Yes that box is definitely checked. – ge0m3try Nov 11 '16 at 17:43
  • I also have a relatively old laptop running Windows 10 that wouldn't connect to my WiFi network when it first started unless I logged in and ran the built-in network troubleshooting application. Ultimately, I fixed that problem by disabling Fast Startup within the Power Options. Something to consider. – Run5k Nov 11 '16 at 17:47
  • If you configured to Connect even if the network is not broadcasting and disabling the Fast Startup function didn't alleviate the problem, it sounds like the root cause is more likely to be related to juggling between a few different versions of the drivers. – Run5k Nov 11 '16 at 20:48
  • What I did was install the Intel driver first...when that didn't work, I rolled back to the factory driver, uninstalled it, and then installed the HP driver. – ge0m3try Nov 11 '16 at 22:13
1

Like it was mentioned earlier - the problem is connected with Fast Startup service working in Windows 10. When you "Shut down" your computer, in fact it hibernates and save your current settings. But when you reboot, Windows initialize a fresh start instance.

I have got similiar problem with my USB Wi-Fi adapter. But I had to reinstall drivers each time when I reboot it from 0, by skipping Fast Startup.

| improve this answer | |
  • But the setting beside Fast Startup specifically says that restart is not affected, however I gave it a try. The first of three reboots did not result in a connection, while the other two did, with that setting off. However, one shut down, then power on, did not connect, while another did. Maybe I didn't wait long enough for the connection though. So, would the conclusion be that if 'Fast Startup' service was working properly, restart actually wouldn't be affected, but considering that Fast Startup is not working properly, restart is affected? – ge0m3try Nov 11 '16 at 20:33
  • I ended up doing a few more restarts and Shut Downs and now neither are working. – ge0m3try Nov 11 '16 at 20:39
1

Since it may alleviate the problem, the steps necessary to disable the Fast Startup function within Windows 10 are relatively simple:

  1. Press WinKey + X
  2. Select Power Options
    Power Options
  3. Select Choose what the power buttons do on the upper-left
    Choose what the power buttons do
  4. Select Change settings that are currently unavailable
    Change settings that are currently unavailable
  5. Scroll to the bottom of the window and uncheck the box associated with Turn on fast startup
    Turn on fast startup
  6. Click the button to Save changes
  7. Reboot your system

(Source)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.