7

This was asked before but I'm gonna ask it again because the solution for the previous answers no longer works, (since MS took off the registery key in Redstone 1).

So my problem involves Cortana search. Whenever I search for a non-installed exe standalone, it cannot find it.

This is NOT a Windows Indexing issue, for this is happening on all my computers, including one with a clean install + my friends computer. (plus I rebuilt indexing and everything under C:\ is indexed)

This is ONLY for standalone exe's. It can find all files (.xml, .pdf, .doc, .random) EXCEPT exe's.

To reproduce this bug

  • Open up Notepad
  • Write a blank document, something like "hello" and save it as something.exe
  • File -> Save as -> Save as type: All files -> something.exe
  • Try searching for the file in Start search, you won't be able to find it UNLESS you rename it to something.random (or anything BUT exe)

I'm a developer and therefor I have lots of exe's compiled by Visual Studio, and I want to be able to find and run them easily from Start. Not only that, but I also want to open portable apps.

Any fix for this? It's really bugging the hell out of me and I want to downgrade to Windows 7 again.

7
+100

The answer by user Zac Pullar-Strecker is correct : EXEs are filtered out if they reside in a location that is not known to Windows 10. After all, Windows 10 is the "safest Windows ever".

One solution to this problem is to add your folders to the PATH environment variable. A useful and free utility for editing the PATH is System Path Commander.

Another solution is to create shortcuts to your EXEs in some sub-folder of the Start menu. The LnkAllToStart script can be used to automate adding all EXEs from the current folder to "%APPDATA%\Microsoft\Windows\Start Menu\Programs\<your sub-folder>.

4

From what I can tell, you can't. Exe files that are not included in registry entries (Installed applications.) Can't be found through start search. While they are indexed, they are filtered out of the search. Some people found you could disable this on earlier win 10 builds with the powershell command:

Get-AppXPackage -Name Microsoft.Windows.Cortana | Foreach {Add-AppxPackage -     DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

But this throws an error on my machine, and I suspect it no longer works.

0

I had the same problem, none of the solutions people have posted worked for me, and I don't want to individually add every directory to my PATH. I verified that EXE file metadata was being indexed with the ESEDatabaseView.exe utility, everything looked fine. It must be a problem with the start menu.

I extracted all the key names from Cortana.Core.dll and set every one until it started working.

Setting this one worked for me (you may need to restart explorer or reboot after setting it):

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Search]
"BingSearchEnabled"=dword:00000000

I now get search results for EXE files as expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.