1

My my machine is Lenovo Z580a laptop.

My problems is that when i shut down my laptop (using Start > Power > Shut Down) i first get spinning windows circle, then screen goes black like it normally should when shutting down, but the fan never stops spinning and LEDs of my sensor keys and the power button stay lit forever. Until I press and hold power button for 5+ sec to forcefully turn it off. If I select Sleep instead of the Shut Down option, it will do pretty much the same - keep LEDs lit and fan spinning forever or until forced off with power button.

What's interesting is that when I use Start > Power > Restart, it works correctly. I get spinning windows circle, then the screen goes black, then fan STOPS and LEDs fade, then it starts again. So it seems like reboot/restart actually turns the machine off and on successfully, where Shut Down doesn't.

I tried it on 3 different OSs: Windows 10 (installed today), Windows 7 (issue initially appeared yesterday when I had it installed) and LiveUSB Linux Mint. On Linux Mint the issue is the same: shutdown doesn't work properly - it never stops the fan and LEDs, but restart works as intended.

What I tried:

  • Set default BIOS settings. Flashing an older BIOS version, and then reflashing the newest available on the Lenovo website. (BIOS shoudn't be the case, I guess, since I had this same version of it before and never had the same problem).
  • Turning off Hybrid / Fast Startup in Windows 10. Hibernation is also off.
  • OS reinstallation. I've also installed all available drivers from the Lenovo website (They don't have any for Windows 10 so I ended up googling for them or installing versions for Windows 8.1 since no newer ones were available).
  • Disconnecting any external devices that may keep my machine awake. I disconnected everything except the power chord.
  • Safe booting. Same issue. It doesn't turn off when in safe boot.
  • Rolled back Intel MEI drivers (read about that on forums) from version 11.x to 9.0.0 (got on the official Lenovo website).

So far for me it looks like it's some kind of hardware-related issue, but that's only an assumption. It's weird for me that Restart actually manages to shut the machine down, but the Shutdown itself doesn't.

May It be somehow related to MBR/GPT partitioning? This guy http://www.tenforums.com/general-support/33868-unable-shutdown-fully-fan-keeps-running.html seems to have fixed similar issue by following this video guide https://www.youtube.com/watch?v=DQf9YqbD8WI. I didn't try that solution yet since it would be really painful for me to wipe my drive now because of all the university work I have to perform in the nearest couple of days.

If any additional info is required please leave a comment and I'll do my best to provide you with it. Thanks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.