Since late there's been a weird bug on my computer or keyboard, for the key combination of control + 1/2/3 don't work anymore. Which I use a lot to switch around in Chrome. This has been really annoying and I have no idea what causes it. The thing, it works fine when I use the numpad.

I have a Corsair K70, and the operating system I am using is Windows 10. Does anyone know of this problem or is something wrong with my keyboard?

Sorry, to clarify, I was making an example of it being annoying with Chrome, but it happens everywhere.

  • 1
    I am neither psychic or a mind reader and I don't like guessing. What is your operating system? Please edit the question and include this essential information. – DavidPostill Nov 14 '16 at 17:06
  • Have you tried re-installing the keyboard driver software? – Andrew Morton Nov 14 '16 at 18:20
  • My keyboard does not have any drivers from Corsair. Those are only for the RGB versions, thus they do nothing on mine. They are just for controlling colours. – stepper Nov 14 '16 at 18:56
  • @Stepepper OK, thanks for clarifying that. Have you made sure that it is not an extension interering with your key presses: How to open Google Chrome with extensions disabled / turned off? – Andrew Morton Nov 14 '16 at 20:37
  • 1
    Open on-screen keyboard (osk.exe) and try this key combo with it. – PrashantKumar96 Nov 16 '16 at 19:28

If you have Nvidia Geforce Experience installed you may try solution posted on http://www.tomshardware.co.uk/answers/id-3224159/keys-work-ctrl-pressed.html

"...I found a solution (at least for myself). I switched off 'SHARE' on my Nvidia GeForce Experience software. For some reason it was causing conflict." -Rosinho

| improve this answer | |
  • Wow. That worked. Alright thanks Nvidia, that's something that suddenly broke. I'll award the bounty when I can. – stepper Nov 16 '16 at 23:34

If you can reproduce this problem on demand, then I suggest testing with an additional USB keyboard attached and also some testing with the OSK (On Screen Keyboard). Start > Run > type "osk", to open it.

If the additional keyboard and OSK function properly, then your keyboard is probably defective. if they do not, then probably an OS or driver issue.

| improve this answer | |
  • Definitely software, doesn't work with the on screen keyboard and it doesn't work with an additional keyboard. But the combination does also not work in safe mode. – stepper Nov 16 '16 at 19:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.