16

Yes, this is a weird question, but I promise this is what is actually happening. It's 100% repeatable every single time.

I've got a MacBook Pro with El Capitan, and hooked up to it I have a Logitech Performance MX mouse with a 2.4GHz wireless receiver. For about the past two weeks, whenever I close Chrome my mouse completely stops responding. I've waited up to 5 minutes and the mouse never responds. If I unplug the wireless USB receiver and then immediately plug it back in, my mouse will start working immediately... at least until the next time I close Chrome.

You might ask, "why would you close Chrome then?" Well, I wouldn't, but I'm a web developer. As part of my grunt build process Chrome is launched to run karma unit tests. There are times when I need to use Command+C to stop the tasks. This of course closes Chrome and then my mouse stops working. If I manually close the browser karma launched (without stopping the grunt process) the mouse also stops working.

The problem is unrelated to grunt/karma because if I close the Chrome browser I'm writing this question in -- a browser I manually launched -- my mouse also stops working. It ONLY happens when a Chrome process completely stops. I can close tabs without affecting my mouse. I can open a second window and close it and my mouse works just fine. I can open an incognito window and close it, and my mouse is also fine. If I close the last open Chrome window though my mouse completely stops responding immediately.

I can close any other program and the mouse also works just fine. I should also mention the built in touchpad never stops working... but I keep the MBP lid closed almost all the time.

I probably end up starting and stopping my grunt process 10-20x a day, and this has become a huge inconvenience (although one my co-workers find pretty amusing). Does anyone have any ideas on how to even begin to troubleshoot this?

  • I have the same issue, and also happens when I quit Slack. A work-around that I have been using for many months is to open the "Login Window" (using trackpad) and then log back in. It is a pain to do... – chaimp Jul 7 '17 at 2:11
  • Same here, I noticed my issue with Slack. – moxi Oct 25 '17 at 17:29
  • Adding a "same here" also with Slack. I opened a ticket with Logitech as I think it's a bug in LCC, but it's hard to get it registered as such. They have offered to possibly replace my trackball, but I don't think it's a hardware problem. I'm already on LCC version 3.9.4. – Jim Brandt Dec 1 '17 at 13:09
  • Also observed with Atom and presumably other Electron based apps. – Tamlyn Jan 12 '18 at 15:15
8

I figured out a solution. I had Logitech Control Center installed, and it appears that something in either OSX or Chrome changed and broke some kind of interaction between LCC and Chrome (I had not updated LCC previous to this issue). When this began happening the first thing I did was install the latest version of LCC for El Capitan, but that did not fix the problem.

After posting this thread I decided to see how to completely remove LCC and fortunately it ships with an uninstaller. As soon as LCC was uninstalled, I could close Chrome and my mouse kept working. I then reinstalled LCC and could still close Chrome. Guess it got into some kind of bad state and only uninstalling first could fix it.

Using the LCC uninstaller:

  1. Go to Applications > Utilities
  2. Run LCC Uninstaller.app
  3. Restart computer (this step is probably optional but couldn't hurt)
  • I have the same issue. I also figured out that closing Google Chrome was the cause of this issue. Uninstalling and reinstalling LCC works for a while, but the issue reappeared for me after a few days. Have you not run into this issue since posting your answer? – Bart Jacobs Jan 13 '17 at 16:04
  • The problem did not reoccur for me, but starting beginning of December I switched jobs and no longer have the Logitech mouse connected to the same MBP. – Mordred Jan 14 '17 at 0:30
  • 1
    Worked for me too (so far). – cweekly Jun 14 '17 at 16:40
3

I had the EXACT same issue - I kid you not. Every time I quit out of Chrome, my mouse was dead. I'd unplug and replug the little receiver and it would come back to life - every time 100% repeatable. The solution? UPGRADE LOGITECH CONTROL CENTER software. I was running 10.10.x and had Version 3.6 of the LCC. I upgraded to 3.9.4 and everything is working well now. Did this work for you? You have to download the program manually from logitech then install it and restart.

  • Months later still problem free for me... – Scott Oct 26 '17 at 18:07
  • Moved from seperate answer by michelinium into comments: I can confirm that newer version of Logitech Control Center fixes this issue. I downloaded and installed version 3.9.7.56. It automatically removed previous version (3.3). Now mouse works fine without freezing. – Albin Nov 10 '18 at 10:43
0

I had the same issue as well. I finally fixed it by opening the Logitech Control Center then Opened Unifying Software. Click 'Advanced' then Unpair and then Pair it again.

Before this I had tried everything else on this form and others. This finally worked for me.

  • Did it fix the problem permanently or do you have to do it every once in a while? Of course, it does not matter. The OP has already received an answer. – user477799 Mar 23 '17 at 14:41

protected by Community Nov 10 '18 at 11:02

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.