4

I use the AutoFill feature in KeePass, which chooses which entry to fill by detecting its name in the focused window's title.

Therefore, when I activate AutoFill on any page in Google Chrome, KeePass detects "Google" in the window's title and either :

  • if the website is in my password database, shows me a dialog to choose an entry to fill, between the site I was on and Google,
  • if the website is unknown, autofills my Google credentials in this random website.

This is not very practical and leaves me worried about the security of my Google account.

How can I configure KeePass to ignore the " - Google Chrome" part of a window's title ?

  • I suppose you are using it under Windows, but, which version, 1.x or 2.x? – NuTTyX Nov 15 '16 at 21:00
  • I use version 2.x. – Elzo Nov 16 '16 at 23:49
2

There is an option under the Advanced tab which toogles matching if a keepass entry's title is contained in the target window title which you can turn off to avoid that behabiour (at least under keepass 2.x, I do not longer have 1.x installed so I cannot confirm there is such option in the older version)

Nevertheless, that could render most of your auto-type features disabled if you do not customize each entry to have a target window, so you might need to modify most of your entries.

A workaround could be changing your google's title to be "My main Google account" (or whatever you like) to avoid the matching in "Google Chrome" and keep the advanced option I mentioned early enabled (you may still need to add target window(s) to match your google's entry.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.