1

I've got a home network and two DD-WRT routers that I'm trying to use lieu of hubs (working with what I've got); and trying to connect to my ISP's fiber-modem router.

My network architecture is as follows:

enter image description here

I can't change too much about the ISP's modem/router without voiding more than half of my warranty stuff, but I can obviously do whatever I want with the DD-WRT routers. And although I can get them all to see the internet, I can't get them to access eachother for gaming and filesharing. How do I need to change settings to allow this? In the past, when I've had the computers on the same router, it hasn't been a problem, so I'm pretty sure it's a router setting.

migrated from serverfault.com Nov 16 '16 at 4:28

This question came from our site for system and network administrators.

  • 1
    Use the LAN ports on the routers to connect them to each other. Then connect the WAN port on your "primary" router to the ISP modem. – joeqwerty Nov 16 '16 at 4:02
  • So don't use the wan ports on the secondary routers at all? – liljoshu Nov 16 '16 at 4:04
  • 2
    No. Using the WAN ports would put the devices connected to each router on a different network, effectively isolating each set of computers from the other. Using the LAN ports will put the devices all on the same network. The only router that needs to use the WAN port is the "primary" router to connect to the ISP modem. – joeqwerty Nov 16 '16 at 4:07
  • 1
    As an aside, you certainly could create two separate networks and configure routing and firewall rules between the two, but that's needlessly complex and isn't what I think you're trying to accomplish. – joeqwerty Nov 16 '16 at 4:14
0

With suggestion from joeqwerty, I took the suggestion of removing the ethernet cables from my Primary Router to the WAN ports of of my DD-WRT routers, and instead connecting them to standard ports.

Although this did allow communication of devices on the sub-routers, they also lost web connectivity.

After working with the settings, web connectivity on the devices under the DD-WRT was restored with the following changes to the DD-WRT routers...

  1. Setup -> Basic Setup -> WAN Connection Type -> Connection Type -> Disabled
  2. Setup -> Basic Setup -> Router IP -> Local IP -> (Choose a Static IP for DD-WRT Router, I chose 192.168.1.50 for one and 192.168.1.25 for the other.)
  3. Setup -> Basic Setup -> Router IP -> Subnet Mask -> 255.255.255.0
  4. Setup -> Basic Setup -> Router IP -> Gateway -> (Primary Router IP, probably 192.168.1.1.)
  5. Setup -> Basic Setup -> Router IP -> Local DNS -> DNS Server (I used Google's 8.8.8.8)
  6. Setup -> Basic Setup -> Network Address Server Settings -> DHCP TYPE -> DHCP Forwarder
  7. Setup -> Basic Setup -> Network Address Server Settings -> DHCP Server -> (Primary Router IP, probably 192.168.1.1.)

Bonus. There's also a setting: Setup -> Basic Setup -> WAN Port -> Assign WAN Port to Switch - Activating it would likely give an extra port to work with. (And likely would have made me not need to switch the cables). That said, I had already switched cables, and had plenty of ports, so didn't feel like bothering, but doing so is probably the better course of action in the long run.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.