1

After a recent update to Chromium on Ubuntu 16, the browser now seems unable to access many sites behind HTTPS, like Amazon's AWS Console, reporting:

Your connection is not private

Attackers might be trying to steal your information from console.aws.amazon.com (for example, passwords, messages, or credit cards). NET::ERR_CERTIFICATE_TRANSPARENCY_REQUIRED

It seems unlikely that Amazon doesn't know how to create an SSL certificate or is trying to "steal my information", and sure enough, the URL works perfectly in Firefox, so my guess is this is some odd bug in Chromium. I tried reporting this error to AWS, and they explicitly said it was a bug in a recent version of Chromium/Chrome.

However, unlike Firefox, Chromium doesn't provide any option to make an exception. Until this is fixed in Chromium, how do I disable this check or exempt certain domains that I trust?

  • Are you certain you updated Chromium recently? Chromium requires Certificate Transparency in order to trust Symantec certificates (due to Symantec issuing certificates for domains not owned by the requester including Google), and the Certificate Transparency logs list built into Chromium expire 10 weeks after build date, which means that if Chromium isn't updated every 10 weeks, it will stop trusting Symantec certificates (including Amazon). Apparently, Ubuntu hasn't updated the chromium package in the last 10 weeks, which triggers this time bomb. – user2313067 Nov 16 '16 at 18:40
  • have you tried to install from there ? chromium.woolyss.com/#linux – thoroc Nov 17 '16 at 13:01
1

Looks like the chromium team have fixed the issue. They have released an update. So to fix run:

sudo apt-get update
sudo apt-get upgrade

Worked for me, hope that works for you too.

|improve this answer|||||
0

Edit your network interface then add google dns :

sudo cp /etc/network/interfaces /etc/network/interfaces.old
sudo nano /etc/network/interfaces

add the following line:

dns-nameservers 8.8.8.8 8.8.4.4

Restart networking

you can also edit /etc/resolv.conf by adding the nameservers as follows:

For IPv4:

nameserver 8.8.8.8
nameserver 8.8.4.4

For IPv6:

nameserver 2001:4860:4860::8888
nameserver 2001:4860:4860::8844

Write protect your file: chattr +i /etc/resolv.conf

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.