1

I've managed to jump through the hoops to be able to boot from a USB drive, and go through the installation process for Linux on my Chromebook, a Lenovo 100S.

For some reason though, after completing the installation, I reboot my computer and SeaBios says "No bootable device."

If I wait around, then it tries to boot into ChromeOS but it of course can't since I replaced it with Linux.

I've tried using Fedora 24 and Ubuntu 16.04, and neither worked after the installation, though both work perfectly fine from the live USB.

I'm not sure where to begin debugging this, so any help would be appreciated. I'm using the RW_LEGACY ROM from John Lewis.

1

Haven't used it myself but this script lets you specify the default boot target:

https://mrchromebox.tech/#fwscript

  • Yeah, I got some help from MrChromeBox on Google+. Turns out I had to use that script with the BOOT_STUB ROM. Here's the thread in case anyone else wants to check it out. I was able to boot normally with the RW_LEGACY ROM, but I unfortunately had no sound. With BOOT_STUB, sound is working fine, but I'm still having issues with bluetooth, as you can see from the thread. – Billy Brawner Nov 22 '16 at 15:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.