45

I've set keyboard languages: ENGLISH-US (not United Kingdom!) and ქარ (my local language).

Sometimes, I see that "ENGLISH (UNITED KINGDOM) [now "United States-International"] keyboard layout is added automatically in my keyboards list.

enter image description here

However, in Control Panel/Languages, it is not listed, neither shows in PowerShell:

$list = Get-WinUserLanguageList; echo  $list[0]; echo $list[1];echo $list[2];

so I can't even remove it! Even adding/removing doens't help!

enter image description here

It has become overly annoying, YEARS HAS PASSED but I can't stop it, can't uninstall. (update: I've posted my answer too below).

10
  • 1
    have you tried what one might've tried in win7 or xp and maybe even 98? like going to control panel..languages.. and seeing if it's there and removing it if you don't want it. or if it doesn't have it then windows 10's equivalent, have you looked into that? (though it probably does have it).. so you should mention what happens when you tried that.
    – barlop
    Nov 17, 2016 at 19:19
  • 1
    as i mentioned, UK is not even in CONTROL PANEL>LANGUAGES. At this moment, I've found something here , and set them to US: i.imgur.com/wKTn24e.png (i dont know what it will do.. i will keep you updated).
    – T.Todua
    Nov 17, 2016 at 20:04
  • 1
    I'm not sure why Windows is using two different fonts in the topmost entry. Is the screenshot altered in any way? If so, please include a new screenshot so we can see exactly what you see.
    – Ben N
    Dec 8, 2016 at 15:51
  • 1
    This magic manipulation may reset Keyboard settings : Open Control Panel > Language. Move another language to the top of the list, to make it the primary language, then again move your existing preferred language back to the top of the list.
    – harrymc
    Dec 9, 2016 at 8:54
  • 1
    Having the very same problem. I'm using EN-US and DE-DE both with only one custom DE-T2 layout and every now and then these language's default layouts appear even without me changing input language.
    – Mario
    Dec 10, 2016 at 7:56

10 Answers 10

16

Add ENGLISH-UNITED KINGDOM keyboard and remove it

5
  • Unfortunately, did not work for me.
    – psycho brm
    Aug 11, 2018 at 20:11
  • 3
    Would never have imagined that this was the solution, but it was. Thanks! Dec 17, 2019 at 7:29
  • This solution worked for me when I couldn't get rid of US English keyboard after installing the Japanese IME keyboard. Jun 23, 2020 at 12:36
  • This is the solution I have been using for years when Windows decides to add a keyboard layout without adding it to the language settings. I often need to add both Danish language and Danish keyboard to the US Language to fully remove it. After doing both, the keyboard layout widget on the taskbar finally disappears. After a while, I have to do it again though, usually every few months.
    – larsch
    Apr 26, 2021 at 13:54
  • This worked for me. For some reason the UK keyboard was appearing in my keyboards list as OP described above. This morning, that keyboard became selected somehow, and typing shift-2 was generating the " character, not the @. Adding the English UK language, and then removing it solved the problem of having a UK keyboard layout choice. Now I no longer see an ENG input button in my task bar. Jul 28, 2021 at 15:45
6

== Method 1==

The best way turned out to avoid United Kingdom during Installation of Windows. That moment, as your KEYBOARD INPUT, you should choose this:

English (United States) [if not shown, then English (International/US)]

== Method 2==

Click start and run this command directly:

powershell $LangList = Get-WinUserLanguageList; $MarkedLang = $LangList | where LanguageTag -eq en-GB; $LangList.Remove($MarkedLang); Set-WinUserLanguageList $LangList –Force;

== Method 3 (WORKED BETTER) ==

What worked for sure, was :

  1. Go to Language preferences
  2. There you should have added two languages: United States and United Kingdom
  3. For both languages, click Options > Add keyboard and add whatever you see containing "English [US/United Kingdom/International]" add all them.
  4. Then, after added all ENGLISH/US/United Kingdom/International Languages & Keyboard in all of them, **REMOVE ALL ENGLISH LANGUAGE ** packs.
  5. Then re-add only English (US / United States)

== Method 4 (Might be best) ==

Go to Languages > Administrative settings > Copy settings > [check the 2 checkboxes] and OK & Restart ("Restart later" doesn't exist!) enter image description here


Update: to say frankly, none of them were able to fully remove UK package from my Win10. Enormously frustrating, years gone, MS still forcefully kick UKs still..

4
  • 3
    4th method is the only this is helped me at last. thanks!
    – Dimanoid
    Jan 31, 2021 at 10:14
  • I have the same problem with Windows 10 Enterprise. Nothing helped - after restart UK start appearing again. Not able to paste screenshot, but in "new user accounts" I have English UK set and unable to change it.
    – void
    Feb 1, 2021 at 19:04
  • Thank you for this. Method 3 is what have been doing for years now when Windows decides to add Danish keyboard layout, without it actually showing up under Language settings. Method 4 is probably a hint of what causes this; If Danish is the default language for new users, Windows might be re-installing it whenever some upgrade or installation modifies system accounts?
    – larsch
    Apr 26, 2021 at 13:50
  • Please don't just edit other people's answers in to your previous answer. If you like their answer, consider up-voting theirs instead. Then we'll know which methods actually work as well!
    – c z
    Nov 3, 2021 at 11:55
2

I'm not sure what you've already tried but here are some possible solution that might help you out.

Override default input method

If you go to: Control Panel > All Control Panel Items > Language > Advanced settings

You will see an option to override default input method. You can set this to your wanted keyboard setting.

If you click on Change language bar hot keys (see image bottom) you can change the ALT+SHIFT or CTRL+SHIFT hotkeys. A button in the Advanced tab will say Change key sequence. You can put them on non assigned.

(this is a response to a question similar to this from someone else)

2

You can do that using PowerShell, running on system startup:

powershell command
powershell Set-WinUserLanguageList -LanguageList en-US

Another thing might be needed to uninstall UK package:

Lpksetup /u
3
  • 1
    It does't only until the next restart. Jul 9, 2018 at 7:51
  • This worked for me. - powershell $LangList = Get-WinUserLanguageList - powershell $MarkedLang = $LangList | where LanguageTag -eq en-GB - powershell $LangList.Remove($MarkedLang) - powershell Set-WinUserLanguageList $LangList –Force => restart computer Aug 14, 2018 at 11:30
  • @VuttipongL. applied the same, worked, but after each restart UK appears again.
    – void
    Feb 1, 2021 at 20:28
1

I've found the solution here.

To fix this issue, delete the Preload registry folder and restart (or sign out) the computer:

HKEY_USERS.DEFAULT\Keyboard Layout\Preload

...

I have created a RemovePreload.reg text file with the following content, this way this fix can easily be re-applied every time without navigating the registry:

Windows Registry Editor Version 5.00
[-HKEY_USERS\.DEFAULT\Keyboard Layout\Preload]

To use this, save it in a text file and change the extension from .txt to .reg. Then whenever it comes back, you can just double click it and restart or sign out.

1
  1. Try Control Panel -> Clock, Language, and Region -> Language
  2. Now change everything to the way you want it to be.
  3. When you are done, go to: Change date, time or number formats (left panel) -> Administrative (tab) -> Welcome screen and new user accounts (group box) and click on "Copy settings...". In "Copy your current settings to" select:

    • "Welcome screen and system accounts"
    • "New user accounts"
  4. press OK.

Now all is left is to hope for the best because I don't remember if that's the right solution for the right problem.

1

When windows was installed, what was the default language? Images normally have major languages included with them but additional languages need to be downloaded from windows update. Its probably just going back to the Image default language when this happens.

1

Try this...

Open PowerShell as an administrator & type these commands.

Get-WinUserLanguageList
New-WinUserLanguageList en-US    
Set-WinUserLanguageList en-US

After that, you can add your local language later.

Reference: https://www.reddit.com/r/Windows10/comments/8i7ctr/cant_remove_english_uk_language_windows_10_build/?ref=share&ref_source=link

1
  • 1
    This did the trick for me! Now I don't have to type in British
    – OpherV
    Jan 29, 2020 at 18:06
0

I've found a few references in Windows 8, but apparently according to this thread maybe it could help you: https://answers.microsoft.com/en-us/windows/forum/windows_10-other_settings/windows-keeps-automatically-adding-en-us-keyboard/69aaea0d-f588-4d54-89fa-a632ae7bced3

It seems to be one of three issues (see the site for more details): 1) Uncheck "Let me set a different input method for each app window." in language settings, 2) Make sure your region is set to your preference, 3) In Privacy settings, turn your location off.

Hopefully that helps.

-1

An application is likely programmatically adding this. Do you use anything like HP iLO or Dell's DRAC? I wrote an app that used LoadKeyboardLayout to add a keyboard layout and the same symptoms appeared (it wasn't in Control Panel but it was in the language switcher).

I've noticed HP iLO plays with keyboard layouts too so that the layout reflects whatever the server is set to.

Not the answer you're looking for? Browse other questions tagged or ask your own question.