This is about Mac VLC, I'm using version 2.2.4 Weatherwax (Intel 64bit), running OSX Mavericks on a 2011 iMac.

I regularly watch series' of videos in VLC, particularly tutorials that often have 50 to 100 or more total videos, each being fairly short. In the past I've had no issues starting at the first video and playing through, since they default to opening in filename order which in my case are always prepended with a numeric sequence like:

01. video1.mp4
02. video2.mp4

All of a sudden today however, videos are jumping around randomly every time each one ends (or I skip to the next). I can identify no pattern, it's just all over the place. In troubleshooting this, I discovered that there is a preference "Play files randomly forever" which for some strange reason is always enabled every time the program is launched. I have disabled this but it made no difference.

I've tried everything I could think of and find online to address this, including:

  • Deleting the VLC config prefs file
  • Clicking the "Title" header of the playlist window to sort in Title order
  • Using the Advanced Open dialog to manually add a folder full of files
  • Right clicking the list of files in VLC to sort
  • Drag & Drop into VLC from Finder
  • Selecting various View menu options for sorting by other criteria
  • Other stuff I can't even remember at the moment

Regardless of how I have the files sorted visually in VLC, they will never play in the order displayed on screen. It's driving me nuts and I can't seem to make any headway in solving it, so I'm hopeful someone here can suggest something I haven't already explored from other questions or internet posts.

  • 1
    I can't verify this well enough to submit it as an answer, but check out these two VLC forum posts: forum.videolan.org/viewtopic.php?t=103242 and forum.videolan.org/viewtopic.php?t=99014. It looks like the option in the preferences pane is overridden by an option in the UI. – edaemon Nov 17 '16 at 20:40
  • Strike my previous comment, so there is no "Random" button, but there is a MENU ITEM under the Playback menu. Whew! What a huge annoyance that way! – JVC Nov 17 '16 at 20:50

Turns out that the "random" playback option is actually hidden in the Playback menu, and the preference will not actually disable it at all. So to stop this behavior, just to to Playback and uncheck Random. Thanks to @edaemon for pointing me in the right direction!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.