1

I'm trying to set the DNS server in Windows 10, and it works fine, but every time I restart the computer, it goes back to the default settings.

I'm trying to set a DNS server that's different than the one provided by my home router (the default), so perhaps DHCP is interfering? This doesn't fully explain it because I don't have this problem running Linux on the same computer.

  • It has been several days since we heard from you. Have you made any progress? – Run5k Nov 23 '16 at 1:21
2

If you have DHCP enabled, it is a safe bet that it is overwriting all of your settings each time you reboot.

To utilize different DNS servers on that machine, you could potentially configure that computer with a static IP address that falls outside the range of DHCP addresses that are being automatically assigned. Include the "new" DNS server IP addresses within that configuration, and everything should be retained when the computer restarts.

Fill out all of the fields within the red boxes:

enter image description here

| improve this answer | |
  • Just a note that you can statically configure just the DNS servers but still obtain an IP via DHCP. So you only need to select and fill in the bottom outlined section. I know this works, I've had to do it before. – milli Nov 23 '16 at 20:04
  • @milli , that is absolutely true and I have previously done the same. But based upon the author's original post, it sounds like he might have already done that so I decided to recommend doing setting both fields to static IP addresses in order to be thorough. Hopefully he will return to this question to provide us with some feedback. – Run5k Nov 23 '16 at 20:10
  • Yes, your solution did work. Thank you! Amusingly, I found that if I select "Validate settings upon exit," it'll actually suggest reenabling DHCP again. – PunctualEmoticon Nov 25 '16 at 19:35
  • That is good to hear, and I'm glad to help! – Run5k Nov 25 '16 at 19:38
1

I've been having the same problem tonight. Compounding the OP's issue I was trying to go the other way as I was failing to access the AD domain and DC's correctly; from a persistent static everytime I rebooted trying to make it remember I'd changed to use DHCP. Kept reverting to static.

Beat head off a brick wall using the old non-Metro network connection settings to switch to DHCP as screenied in Run5k's answer above wasn't working. It changed the setting fine in the session but still couldn't access AD/DC. As soon as rebooted would revert.

Happening across the IP Settings section in the new Metro network configuration section of the Windows 10 Settings pages to switch from static to AutoMatic DHCP; automagically everything just started working; picked up the DC, immediately required me to update the cached network password (instead of requiring an old no-longer used one) and I gained full AD access. No huge surprises that the temporary port of the old familiar control panel dialogs isn't working quite correctly any more... just a shame the new UI is so pants... Upon reboot, remembered the new setting.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.