0

I just completed my PC build: i3-6100 CPU msi b150 gaming motherboard XFX Radeon RX480 8Gb Corsair CX 450M PSU

So I installed the GPU on the first slot, the x16. It didn't work. I get no picture, but when I plug my cable in the integrated graphics, there is picture. The GPU lights up and the fans start spinning, so it's getting power. Then I tried putting it in the other slot, the x4 one. It works normaly, it gets detected and I can use it that way.

Why is that happening?

  • Radeon RX graphics cards are not listed as compatible with the MSI B150 motherboard > msi.com/Motherboard/support/B150-GAMING-M3.html#support-vga – Jim Nielsen Nov 19 '16 at 2:25
  • Really? Is that the reason? – Христо Христов Nov 19 '16 at 2:29
  • Is there a setting in the BIOS for "initial display adapter" or something like that? – Android Dev Nov 19 '16 at 2:33
  • In most cases when you have a fairly new graphics card and the MB vendor does not have it listed as compatible, it'll work but cannot guarantee to work in optimal conditions. That said, MB vendors release BIOS updates to provide support for newer hardware, so i'd suggest you grab the latest bios from MSI released Nov. 3rd 2016 and check again using the 16x slot. > msi.com/Motherboard/support/… – Jim Nielsen Nov 19 '16 at 2:48
  • there is: Initiate Graphics Adapter. There are 2 options PEG and IGP. It's always set to PEG – Христо Христов Nov 19 '16 at 2:49

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.