1

For some reason, my Windows 7 x64 (7601) console font changed to some small unreadable size, and when I try to set it back (in Default or Properties), the default font size, i.e. 8x12, is not present there. There are only sizes like 8x8, 7x12, and all the others, but the 8x12 size is simply removed from there. How can I get it back? Can I set the size somewhere in the registry?

Edit: It happened after I changed the system DPI to some other value and back. Then the console size went down to 4x6.

0

The Raster Font (not TruType Fonts) issue, it would be due to missing system file(s):

  1. Press Win + R
  2. Type sfc /scannow (requires admin rights)
  3. Restart your system

Now check again, whether your font size was restored or not

0

I've found the same issue here, and it was apparently solved by changing the system locale to English and back. I did that and it worked, now 8x12 is back there again.

Here is my registry:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Console]

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Console\Nls]
"00000412"=""
"00000804"=""
"00000411"=""
"00000409"=""
"00000404"=""

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Console\RasterFonts]
"woafont"="dosapp.fon"
"CGA40WOA.FON"="CGA40WOA.FON"
"CGA80WOA.FON"="CGA80WOA.FON"
"EGA40WOA.FON"="EGA40WOA.FON"
"EGA80WOA.FON"="EGA80WOA.FON"

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Console\TrueTypeFont]
"0"="Lucida Console"
"950"="*細明體"
"932"="*MS ゴシック"
"936"="*新宋体"
"00"="Consolas"

[HKEY_CURRENT_USER\Console]
"ColorTable00"=dword:00000000
"ColorTable01"=dword:00800000
"ColorTable02"=dword:00008000
"ColorTable03"=dword:00808000
"ColorTable04"=dword:00000080
"ColorTable05"=dword:00800080
"ColorTable06"=dword:00008080
"ColorTable07"=dword:00c0c0c0
"ColorTable08"=dword:00808080
"ColorTable09"=dword:00ff0000
"ColorTable10"=dword:0000ff00
"ColorTable11"=dword:00ffff00
"ColorTable12"=dword:000000ff
"ColorTable13"=dword:00ff00ff
"ColorTable14"=dword:0000ffff
"ColorTable15"=dword:00ffffff
"CursorSize"=dword:00000019
"EnableColorSelection"=dword:00000000
"ExtendedEditKey"=dword:00000000
"ExtendedEditKeyCustom"=dword:00000000
"FontFamily"=dword:00000000
"FontSize"=dword:00000000
"FontWeight"=dword:00000000
"FullScreen"=dword:00000000
"HistoryBufferSize"=dword:00000032
"HistoryNoDup"=dword:00000000
"InsertMode"=dword:00000001
"LoadConIme"=dword:00000001
"NumberOfHistoryBuffers"=dword:00000004
"PopupColors"=dword:000000f5
"QuickEdit"=dword:00000000
"ScreenBufferSize"=dword:012c0050
"ScreenColors"=dword:00000007
"TrimLeadingZeros"=dword:00000000
"WindowSize"=dword:00190050
"WordDelimiters"=dword:00000000
"CurrentPage"=dword:00000001
"FaceName"=""

This snippet doesn't have "949"=... in [TrueTypeFont] thanks to some genius StackExchange filter.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.