1

Versions

  • System: Laptop MSI Apache Pro GE62 2QF
  • Installer: Debian Stretch Alpha 8

This is the log in /dev/tty4:

/dev/tty4 log

Then a lot of lines appear in the log and I couldn't record all of them.

These are the last lines

last lines

Context

I bought the laptop a couple of months ago. I installed Debian Stretch a few weeks after receiving it in the mail and everything was OK, except the WiFi, but installing the proper package from the non-free repo got it working.

That lasted like a week of a not intensive use. Suddenly the DVD tray started opening at random times. No common pattern or way to reproduce the issue, it just happened at an average rate of once per hour.

Not long after that, the first Kernel Panic occurred. From that moment there was no way of getting something productive done with the laptop. Kernel Panics were too frequent.

I run memtester (because memtest86+ didn't work from GRUB) and badblocks. All fine. Then the Intel Diagnostic Tool threw some warnings regarding the power consumption of the CPU.

I tried to reinstall Debian but something fails during the installation every time. I remember the LEDs flashed once indicating a Kernel Panic mid-installation. And now the installer can't detect the WiFi card, which is something that worked the first time. Actually, not even the Ethernet worked. It said my network is not using the DHCP protocol (of course it uses it) and even manually configuring the connection it says every Debian apt mirror has some issue and can't connect to it.

I contact MSI and they gave me the impression of not wanting to deal with this issue. They insisted they don't support Linux. That I should try to install Windows 10.

I convince them to send someone to pick up the laptop, but at the same time I try to install Windows 10. Windows 10 installs OK. I run different memory, CPU, GPU stress programs and nothing weird.

What is going on? I suspect some hardware problem. Why would Debian install the first time but not now?

1

There is a bug affecting Broadwell CPUs. Updating the BIOS will fix it.

If you are experiencing a blue screen error when opening any Office 2016 applications, certain games, and virtual desktop Software, showing a "MACHINE_CHECK_EXCEPTION" or "CLOCK_WATCHDOG_TIMEOUT" BSOD's. This is caused by bug in the Microcode affecting only Broadwell CPU's (5th Gen) and it is resolved by updating the Microcode via a BIOS update


NOTE: The BIOS in the links will fix this issue, but they may not be the latest version available.

0

Sounds like bad/ corrupted install media. Run your md5sums/sha256sums against the iso, then the actual media.

  • I don't have anymore the downloaded iso. I used the netinstall version. I am currently downloading the DVD version (first iso only), I will check MD5 and SHA1 and install it in a different USB. Will update. – BlueSialia Nov 20 '16 at 9:07
  • Well, I managed to install it. But the Kernel Panics (and the DVD tray) didn't go away. And the only thing I can find about the Kernel Panics is this in /var/log/syslog (imgur.com/a/srZr9 minute 53). – BlueSialia Nov 20 '16 at 21:16
  • What is your definition of "kernel panic"? that screencap does not show anything kernel panic. – user657451 Nov 21 '16 at 5:11
  • also. did your md5/sha sums pass? – user657451 Nov 21 '16 at 5:13
  • Yes, of course it passed the checksums. Why would somebody try to execute a downloaded file that didn't pass the checksums? And I know it is a Kernel Panic because the Bloq Mayusc LED blinks. Source: git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/tree/… – BlueSialia Nov 21 '16 at 6:59

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.