0

I have a large storage volume which is composed of 4 x 3.5" Seagate SATA hard drives which are spanned into a single drive via Windows disk manager.

Previously I was running Windows 7 but I recently performed a fresh install of Windows 10 on my separate OS drive.

Since I updated to Windows 10, at least one of the SATA drives has been making a semi-regular clicking noise, like the noise which can happen if the disk is seeking heavily or is just powering up.

I do not think that the noise is a sign of damage; rather I think something is causing the click since this only started happening immediately after the OS upgrade.

More details about the click noise:

  • It is always a single click; not a series of clicks or crunches
  • It occurs roughly every 20-30 seconds
  • It seems to occur only after a period of the disk being idle, although I haven't had time to confirm this. Anecdotally, if I'm using the storage volume then I don't hear the regular click. If I leave it alone and don't use the volume for a while (say 15 minutes?) then I start hearing the click.

Remedies I have tried:

  • Windows Power Settings are already set to "Performance" and the Turn off hard disk after X minutes is set to 0 (i.e. disabled).
  • Used ProcessMonitor to see if any programs are accessing the disk. They are not; at least not as reported by ProcessMonitor, or at least not by its disk label (E:)
  • If it's not a "breaking drive" click, then it sounds like sleep & wake up sounds, maybe it's not really getting told to never sleep, or maybe the drive's firmware got told to sleep every 30 seconds somehow, but something keeps waking it up... try some hard disk / SMART programs to read / set the drive's firmware settings, and double-check windows's "turn off disk" settings a different way (terminal, etc) maybe the settings you're looking at are wrong/being overwritten – Xen2050 Nov 20 '16 at 7:59
0

This turned out to be due to the Advanced Power Management (APM) settings on the disk causing the disk heads to park every few seconds. Not only is this annoying, it is apparently bad for the life of the disk.

I used the CrystalDiskInfo utility to change the APM control to "Maximum Performance" and this stops the clicking. The utility may have to be run after each reboot to maintain the setting.

You can also use something like hdparm to change APM settings.

More information:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.