18

We use unsigned SSL certificates for local development, so we frequently see the "Your Connection is Not Private" message in Chrome. We bypass it by proceeding via the options, but this only lasts a few days or so before the message returns. Is there a way to either whitelist certain domains or have certain certificates always excepted?

I believe chrome://flags/ used to have a place to set "Remember decisions to proceed through SSL errors for a specified length of time" but that is no longer available.

2
  • 2
    Add the certificate to your system keychain add a trusted root. Bonus points if you sign future certs using it (instead of self-signed) so you only have to do this once.
    – Bob
    Dec 18, 2016 at 15:45
  • mkcert simplifies this quite a bit by handling the root cert installation and local cert creation, see github.com/FiloSottile/mkcert Apr 11, 2020 at 4:15

4 Answers 4

29

The best (and only) solution that I have found is to type the passphrase thisisunsafe as soon as you see the “Your Connection is Not Private” message. We have servers on an internal LAN where we regularly get blocked by Chrome. This passphrase is the only way to get to them.

5
  • 3
    Tried a bunch of stuff and this is the only thing that worked. Just reloaded the page and typed in "thisisunsafe" and the page reloaded to what I needed. Thanks!
    – Mav2287
    Jan 30, 2020 at 21:18
  • wish i knew about this a long time ago, had to make my machine trust these certs, which is a bit of a pain...
    – Rob C
    Apr 23, 2020 at 19:48
  • 1
    Dude that was amazing!!! I just typed thisisunsafe and hit enter and it passed right through, I never would have thought of this in a million years Dec 4, 2020 at 17:53
  • Does this whitelist it for good or is simply a keyboard shortcut to clicking 'Advanced' button then clicking Proceed?
    – gregg
    Jan 18, 2021 at 18:06
  • Its usually good for a couple weeks.
    – Hephaestus
    Jan 19, 2021 at 19:03
7

In chrome://flags/ there's a new option named Allow invalid certificates for resources loaded from localhost. that you can enable.

chrome://flags/#allow-insecure-localhost

2
  • +1 but god knows when they'll remove this feature.
    – Nick
    Jul 25, 2018 at 3:09
  • it doesn't work for me. Any ideas?? server is nginx on ubuntu 18.04 chrome is Version 87.0.4280.88 (Official Build) (64-bit). I did restart chrome to have changes take effect.
    – Jadeye
    Dec 27, 2020 at 9:45
2

Have you tried to add --ignore-certificate-errors tag in Google Chrome shortcut to bypass SSL warning? According to this post, it's a method to bypass & ignore the SSL warning.

0

Have you tried adding your own root certificate to chrome? (Settings, Advanced, Privacy & Security, Manage Certificates, Trusted Root CAs, Import)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .