0

A computer on my network has Windows SP1 x64 and Skype v7.3 installed. Everything works fine except for message delivery: incoming and outgoing messages take 1-5 minutes to reach the recipient, however calls go through without issues.

enter image description here

I suspect there's some sort of an issue with the local network configuration. Here's what I've researched so far:

  1. Other computers in the network don't experience the same issues, so it's probably not caused by the router configuration.

  2. Trying to open web.skype.com fails, since the page takes too long to open.

  3. Connecting to the network through a VPN does fix the issue

  4. The hosts file is empty

So the question is: how can I fix/debug the issue with Skype's message delay? Is there a tool I can use to check which of Skype's connection attempts fail/take long to establish?

  • Do you have any custom entries in your hosts file that might be interfering with Skype? I used to have some in there to limit telemetry by Microsoft, but they also messed with Skype. – cascer1 Nov 21 '16 at 12:23
  • @cascer1 hosts file is empty – JonathanReez Supports Monica Nov 21 '16 at 12:26
  • @cascer1 are there any "secret" hosts-like files in Windows? – JonathanReez Supports Monica Nov 21 '16 at 12:27
  • The only hosts file I know of is C:\Windows\System32\drivers\etc\hosts – cascer1 Nov 21 '16 at 12:29
0

Skype uses internet configuration of the machine, try to restore the configuration.

Restore Internet Explorer setting:

Open the Reset Internet Explorer Settings dialog box.

To do this, use the following method

Close all Internet Explorer and Explorer windows that are currently open.

Start Internet Explorer.

On the Tools menu, tap or click Internet options. If you don't see the Tools menu, press Alt.

In the Internet Options window, tap or click the Advanced tab.

Tap or click Reset. If you're using Windows Internet Explorer 6, click Restore Default.

In the Reset Internet Explorer Settings dialog box, tap or click Reset.

Note Select the Delete personal settings check box if you also want to remove browsing history, search providers, Accelerators, home pages, Tracking Protection, and ActiveX Filtering data.

When Internet Explorer finishes applying the default settings, tap or click Close, and then tap or click OK.

Try the web version.

Go to outlook.com and log in using your account. Is the problem present there?

Skype App

Try to reinstall the application, update it or downgrade it to prove if the problem persists.

  • Internet Settings Reset - done, didn't help. Web version fails to open. Skype app - tried latest version, v6 and v5 - same issue – JonathanReez Supports Monica Nov 21 '16 at 12:40
  • Check the antivirus and firewall, some antivirus has add-ons like firewall who might block your traffic. – Alejandra Moreno Nov 21 '16 at 12:41
  • Add extra dns routes in your ethernet-wifi connection, like 8.8.8.8 or 8.8.4.4. – Alejandra Moreno Nov 21 '16 at 12:41
  • Done. Windows Firewall has an exception for Skype and Resource Monitor shows Skype is allowed to connect. Antivirus (Security Essentials) has an exception for Skype. Custom DNS has been disabled, didn't work either. – JonathanReez Supports Monica Nov 21 '16 at 12:42
0

After extensive testing I've realized the problem is that the ISP is blocking some of Skype's servers. Skype seems to try to connect to those servers, fails, and then switches to a fallback server which isn't blocked.

So there's nothing to be done locally, short of using a VPN connection.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.