How can I ditch the rented router CenturyLink gave me and use my own router with CenturyLink Fiber internet? Can I use routers like Orbi or Google Wifi that don't support VLAN tagging?

3 Answers 3


What You Need

  • PPPoE username/password
  • VLAN ID, most likely 201
  • Router that supports VLAN Tagging
  • Or, Managed switch and a regular router

When you sign up for CenturyLink Fiber internet, they'll install a optical network terminal (ONT) somewhere in your house that converts the fiber optical into an ethernet cable. At this point they'll supply you with a router that costs $10 a month to rent. Most likely it will be the C2000T. That piece of hardware is not required; however, to replace it, you'd need router that supports VLAN tagging and PPPoE.

Read to the end to learn how to use ANY router, even if it doesn't support VLAN tagging

VLAN Tagging

Fiber internet uses VLAN tagging to differentiate between internet traffic and television service, or at least, that's how CenturyLink uses it. It's basically like creating a virtual network of computers that can only see each other, even if they're plugged into the same router.


PPPoE basically means that you have a username and password to login to your internet, but not in an AOL sort of way, this is a username and password that is configured on the router device CenturyLink gives you, or you can call and change it. You can login to the C2000T to find your username/password at, or just call CenturyLink and ask them for it.

Supported Routers (with VLAN Tagging)

This list is of routers I tried, the router I ended up using is the ASUS RT‑AC5300. I find it to provide around 800-850Mbps on a wired connection. Typically 20% of your network speed is reserved for network overhead, so this is the best you can hope for on a 1Gbps connection. The CenturyLink router was limiting my speed to around 300Mbps, which is why I wanted to swap it out.

  • ASUS RT-AC87
  • ASUS RT-AC3200
  • ASUS RT-AC3100
  • ASUS RT-AC5300
  • Netgear Nighthawk R7000

Setup Instructions

Firmware Update

Assuming you chose an ASUS router, you'll need to install the ASUSWRT-MERLIN firmware to enable VLAN tagging. You'll login to your router by going to in your browser, using the default login (found in your router documentation) and locate where to update your firmware. If you chose the Netgear Nighthawk router, then VLAN tagging is already enabled.

PPPoE Configuration

Find the internet setup page, which will default to DHCP, change this to PPPoE and you'll then be able to enter the username and password you got from CenturyLink.

VLAN Tagging

On the ASUS router, go to the LAN tab, select IPTV at the top, and on the WAN port, put 201 as the VLAN ID. If you don't see the IPTV tab, make sure you upgraded to the ASUSWRT-MERLIN firmware.

On the Netgear router, go to the Advanced tab, Advanced Settings, VLAN/Bridge Settings. Click "Enable VLAN" and "Enable VLAN Tag". Set the VLAN ID to 201.

How to use ANY router (that supports PPPoE, but not VLAN Tagging)

If you're like me, you probably are excited for Google's upcoming Google Wifi, which is their own version of Eero and Orbi. It's a collection of three access points that you put around your house that provides complete coverage and fast speeds. Sadly Eero does not support PPPoE, so it just won't work. Orbi does, and so does Google Wifi. Most routers support PPPoE.

To make this work, you'll still have to do VLAN Tagging, but that can be performed by a managed switch, which is like a regular switch (or network splitter), but it lets you change settings by logging in like you do a router. I purchased the TP-Link TL-SG105E for $30 at Fry's Electronics, but you can get it for the same price on Amazon.com.

Configure TP-Link TL-SG105E

The TL-SG105E doesn't remember settings after being unplugged if you don't click "Save Config" on the right.

  1. Plug your computer into port 5 of the switch
  2. Go to in your browser
  3. Login with admin for the username and password
  4. Click VLAN on the left
  5. Click 802.1Q VLAN on the left
  6. Enable 802.1Q VLAN Configuration
  7. Click "Apply"
  8. Type 201 into the VLAN ID box, and name it "Fiber"
  9. Check the "Tagged" radio button for Port 1
  10. Check the "Untagged" radio button for all other ports
  11. Click "Add/Modify"
  12. Click 802.1Q PVID on the left
  13. Check Port 1 and 2
  14. Type 201 into the PVID box
  15. Click "Apply"
  16. Plug the cable from the ONT into Port 1
  17. Plug the router into Port 2
  18. Click "Save Config" and confirm


If you chose a router that supports both PPPoE AND VLAN tagging, then the swap is pretty simple. If you want to use any router that supports PPPoE, but not VLAN tagging, then a managed switch will get you there. The setup is a little long winded, but it'll save you $10 a month and allow you to use your own equipment, rather than the subpar router provided by CenturyLink.

If you use PRISM television, then you'll need to configure one of the ports on the managed switch to tag that with the appropriate VLAN ID using the same steps above. I don't have PRISM television, so I can't say if it'll work, but there isn't a reason it shouldn't. You'll need to find the correct VLAN ID in the C2000T settings, or by calling CenturyLink.

Update (Using Google Wifi)

Back in January 2017 I finally got my hands on the Google Wifi 3-pack. The router claims to support PPPoE but doesn't work for some reason. I spent a few hours on the phone with Google and they basically told me that PPPoE is broken and they would work on a fix. I haven't checked recently to see if it is fixed yet. Here is how I set it up.

My internet connection goes into the ASUS RT-AC5300 which does the PPPoE and VLAN tagging. I've disabled all wifi radios on the ASUS RT-AC5300. I then plugged the Google Wifi unit into a LAN port on the ASUS RT-AC5300 and set it up as a regular DHCP router.

The Google Wifi router gives me complete coverage, I have all the other two units hard wired to the main unit (using a switch) and get peak speeds of 800Mbps wired and 400mbps over wifi. I'm very happy with my setup; however, I'd love to get rid of the ASUS RT-AC5300 to simplify setup, but it's not slowing me down. I'll update again when I try PPPoE again (or IPoE?) on the Google Wifi router.

  • The reason I have you plug into port 5 of the managed switch is because if you plug into a port that has PVID applied to it in step 12, you'll no longer be able to login to the switch. You could technically plug into port 3 or 4 as well. You could also enable PVID on any two ports, but that is needlessly complicating things.
    – user96136
    Nov 21, 2016 at 17:56
  • Could you include a generic summary of what parameters are necessary? (Internet uses PPPoE over VLAN x, etc.) Step-by-step instructions only tell what to do but not why, so they're more difficult to translate to different router types. Nov 22, 2016 at 20:08
  • I'm pretty sure my PPPoE and VLAN settings instructions were pretty generic. As for the step-by-step of setting up a managed switch, I only have experience with the one, so I'm not sure how I'd make that generic. I added a "What You Need" heading at the top.
    – user96136
    Nov 22, 2016 at 22:11
  • 2
    The switch/any router solution worked for me! I used a MacBook to setup the switch and had to change my network settings to: WIFI -> disabled, Ethernet-> IPv4: Manually, IP:, Subnet: and then I could connect to to manage the switch.
    – Justin
    Feb 22, 2017 at 17:06
  • Thank you so much for the guide! Followed this and was set up with my Asus OnHub in 15 min! Only thing is that I noticed I have terribly slow upload speeds.. Have used router previously with cable (xfinity) and upload speeds were good, and with the (crappy) router provided by my ISP upload speeds were still 20-30x faster. Can only conclude bottleneck is the switch -- any advice? Dec 20, 2017 at 16:04

That Solution Works, But...

I successfully connected the Google Wifi router to Centurylink fiber using the solution proposed by Patrick (thanks!).

I used the same TP-Link TL-SG105E switch ($30 at Office Depot) and followed his instructions.

However, after several minutes I was unable to find the PPPoE password anywhere in my router configuration settings. That's when I discovered it was using IPoE...

Using IPoE / DHCP

I discovered that the Technicolor C2100T router that centurylink had provided me was configured using IPoE - which is effectively DHCP over WAN.


"Typically, IPoE uses Dynamic Host Configuration Protocol and Extensible Authentication Protocol to provide the same functionality as PPPoE"

Simplified Setup

This means that if you have the simplified IPoE setup like in my case, you can completely skip the PPPoE section.

Just configure the switch to enable VLAN tagging, plug in the Google Wifi and you're good to go. The primary Google Wifi AP will automatically get an IP address via DHCP from Centurylink.

I've tested and it works. I only have 100mbps service, but my test results show a consistent 105+ mbps speed anywhere in my house.

Good luck!


I wanted to share some of my experiences with a PPPoE connection via a MikroTik hEX RB750Gr3 device.

It fully supports PPPoE and VLAN tagging, and based on my gigabit link tests, the CPU is only maxed around 60% during upload or download tests.

Its only a $60 device, and you will need to have APs if your network supports wireless.

I used to use an R7000, but realized it was limiting my bandwidth.

Also, In Seattle (prism – tv services) are configured as IPoE, and Internet only is configured for PPPoE. I recently changed to internet only, and they had to re-provision the backend to PPPoE, which ended up disconnecting my internet around midnight (day of switch over).

Keep in mind that as long as you have the login information for your PPPoE connection, you’re able to just make the configuration changes necessary to do so.

For those needing these config changes, this is the following for the MikroTik

/interface vlan
add interface=ether1 name=e1-v201 vlan-id=201

/interface pppoe-client
add add-default-route=yes disabled=no interface=e1-v201 name=pppoe-out1 password=password user=username

Please make sure that your firewall settings and NAT translation uses the pppoe-out1 interface.

You must log in to answer this question.