2

I'm having problems mounting a CIFS network drive for use in an application I develop/maintain. The share path has a folder in it named , Employees as in Company/, Employees/Some data (the mapped folder is on a Windows domain).

I had to escape the spaces already with the octal \040. The octal \054 for comma does not work - I still get an error. After looking at kern.log, I see it is interpreting the comma literally and breaking the path:

Nov 21 11:15:58 dashboard-prod kernel: [669753.128303] CIFS: Unknown mount option " Employees/Some data"

It seems that it is ending the path there and expecting what followed the comma to be a path option.

Here's the line in fstab:

//path/to/share/, Employees/   /local/path  cifs    defaults,password=foo,sec=ntlm,iocharset=utf8,username=bar   0    0

When I attempt to quote the path (hoping it would escape the comma properly) it does escape the comma properly, but then I get:

mount.cifs: bad UNC ('//path/to/app/, Employees/folder')
  • Have you tried to put some quote around your path? – Angel115 Nov 21 '16 at 20:46
  • when i try to quote the path, it gives me another error. i assumed it was not liking the double quotes. am i supposed to quote both paths together? i was only quoting the one. – WestonM Nov 21 '16 at 20:50
  • 1
    juste the first path continning your special characters. and you say that you've tried //path/to/share/\054\040Employees/ already? what is the new error now? – Angel115 Nov 21 '16 at 20:53
  • yes I have tried using the octals as you describe them. when I do that I get "Unknown mount option" above. when I try just quoting the path, it does translate the path name properly, but then the error it gives me is "mounts.cifs: bad UNC" – WestonM Nov 21 '16 at 20:59
  • 1
    Can you make it work from the CLI, using mount -t cifs ...? – MariusMatutiae Nov 22 '16 at 6:55

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.